locked
KB 2596911 Sharepoint 3.0 SP2 My site is down Help! RRS feed

  • Question

  • need help as we applied patch 2596911 this morning and know one is able to access to sharepoint.

    [SPIisWebSiteWssSequence] [ERROR] [7/16/2012 1:16:32 PM]: Action 3.0.2.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
    [SPIisWebSiteWssSequence] [ERROR] [7/16/2012 1:16:32 PM]: 1387
    [SPIisWebSiteWssSequence] [ERROR] [7/16/2012 1:16:32 PM]:
    Server stack trace:
       at Microsoft.SharePoint.AdministrationOperation.Win32.SPNetApi32.NetLocalGroupAddMember(String groupName, String userName)
       at Microsoft.SharePoint.AdministrationOperation.SPProvisioningAssistant.AddGroupMember(String username, Int32 group)
       at Microsoft.SharePoint.AdministrationOperation.SPAdministrationOperation.DoUpdateGroupMembers(String[] loginsToAdd, String[] loginsToRemove, Int32 group)
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.SharePoint.AdministrationOperation.SPAdministrationOperation.DoUpdateGroupMembers(String[] loginsToAdd, String[] loginsToRemove, Int32 group)
       at Microsoft.SharePoint.Upgrade.EnsureRegKeysAndGroup.Upgrade()
       at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
    [EnsureRegKeysAndGroup] [3.0.2.0] [DEBUG] [7/16/2012 1:16:32 PM]: Begin Rollback()
    [EnsureRegKeysAndGroup] [3.0.2.0] [DEBUG] [7/16/2012 1:16:32 PM]: End Rollback()
    [EnsureRegKeysAndGroup] [3.0.2.0] [DEBUG] [7/16/2012 1:16:32 PM]: Begin Dispose()
    [EnsureRegKeysAndGroup] [3.0.2.0] [DEBUG] [7/16/2012 1:16:32 PM]: End Dispose()
    [EnsureRegKeysAndGroup] [3.0.2.0] [DEBUG] [7/16/2012 1:16:32 PM]: Elapsed time: 00:00:00.0155999.
    [SPManager] [ERROR] [7/16/2012 1:16:32 PM]: Upgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
    [SPManager] [ERROR] [7/16/2012 1:16:32 PM]: 1387
    [SPManager] [ERROR] [7/16/2012 1:16:32 PM]:


    • Edited by magbag757 Tuesday, July 17, 2012 1:55 PM update
    Tuesday, July 17, 2012 1:52 PM

All replies

  • How did you apply the patch? Through automatic updates or did you run the installer yourself? This looks like the output log from the Configuration Wizard. Is this the log from the wizard when you ran it after the update?

    You could try running the following command from the command line (assuming the 12 hive's bin folder is in your path): psconfig.exe -cmd upgrade -inplace b2b -wait


    Jason Warren
    Infrastructure Specialist

    Tuesday, July 17, 2012 5:36 PM
  • This is how I fixed this issue:

    Event logs showed DCOM and MSSQL errors

    I changed the Launch Permissions for System under – Component Services – Computers – DCOM Config – IIS WAMREG admin Service – Security – Edit -  to :

    Local Launch – allow

    Remote launch – allow

    Local Activation – allow

    Remote Activation - allow

    Then I ran the following two commands from a DOS windows opened as administrator:

    (get-spserver $env:computername).NeedsUpgrade

    PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

    SharePoint worked after this process.

    Thursday, July 19, 2012 2:22 PM