Flashing Black Sreen, Everytime I run a 3D Application RRS feed

  • Question

  • Okay I just got a brand new computer yesterday. 

    2 Gig's of Ram....Intel Duo Core 2.8 ghz processor.. ATI Radeon x1550 512 video card.  The Problem:  Whenever I try to run a video game, the catalyst 3d test for my vid card driver, and even when I run one of the screensavers that are default with Vista my screen freezes for a second, flashes a black screen goes back to the failing app, black screen constantly until I stop the 3d app. When I finally get whatever the program was shut down I get a ballon in the bottom right corner saying "Display Driver has stopped running and has recovered successfully"  All my drivers are up to date.

    Running Vista Home Premium 32.  My Desktop looks fine, I can browse the internet and windows media player works too ( haven't tested all apps)  But if I try to run a game that is compatible with vista ( World of Warcraft) it happens.  I have spoken with ATI, my computer manufacturer, and now here.  I have been searching the web for this problem as well, and it seems to be happening to a lot of people with different system set ups and video cards ( ATI and Nvidia) Is there anyway I can stop this from happening so I can start using my comp for what I got it for???

    Thanks for any assistance.

    Thursday, April 12, 2007 1:51 AM

All replies

  • Try to download and install the latest driver from ATI/AMD's website.




    Saturday, July 7, 2007 1:00 AM
  • I've been having the same problems for the past week now, I have all the latest drivers, DID have the latest windows update, reformatted, refused to install the updates again tues morning, after i got rid of those updates, i still get it, but not as bad as with the updates, the updates only way i could turn off the pc was power button, sometimes safe mode would load, sometimes it wouldnt, took me 9 hours to get my pc working enough to boot up to reformat,,, something tells me some of the windows updates is ____ and we installed the ____ that was put out
    Saturday, June 13, 2009 7:58 AM