RDS and ESXi


  • I have an ESXi 5.1.0 server (intel xeon) with 5 VM's running on it. Two of those VM's were intended to be Server 2012 Terminal Services Session Servers. I am new to server 2012, and RDS, and I didn't realize that I couldn't nest the virtualization inside ESXi. I have followed two articles on proper setup of RDS for session host and what I've resulted in is having the web gateway working, but only for RDP access directly into the server since I cannot add the Hyper-V role and begin to setup sessions for those connections to be routed to.

    So I guess my question is two fold; 

    A) Can you confirm that I cannot get RDS up and running on my ESXi Virtual Server 2012

    B) Which virtual environment can this setup exist stably?  

    Tuesday, November 19, 2013 7:05 PM


All replies

  • Dear,

    You can run hyper-v based on ESXi but you have to turn on the "Promiscuous Mode".

    Please check the following link:

    Hope it helps you to accomplish your task.

    If you find this post is helpful please mark it as answer.


    Housam Smadi

    Tuesday, November 19, 2013 8:36 PM
  • Hi,

    For RDS Shared session host servers you do not need the RD Virtualization host (Hyper-V) role.  You can virtualize the RD Web gateway,RD Broker. You only need Hyper-V (RD Virtualization host role) for a VDI deployment or when you need to use RemoteFX vGPU features offered by Hyper-V.

    There some limitations when running Server 2012 VM's on vSphere 5.1:

    Did you use the quick deployment to setup the enviroment?

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    MCSE:Server Infrastructure, MCSE:Desktop Infrastructure, MCSA Server 2012, Citrix CCIA & CCEE, Cisco CCNA, VMware VCP 3/4/5 Twitter: @dnyvandam

    Wednesday, November 20, 2013 8:17 AM
  • I believe this is the actual setup guide that I used to begin with.

    The problem I'm experiencing is that It seems I have the RD gateway and RD Broker configured, but when incoming connections are established there doesn't show any connections in the gateway manager, only the task manager - so it appears to me that it's not connecting into a session but rather just an RDP into the local machine. In troubleshooting this i found an article that directed me to add the hyper-v role, which I can't add because "it's already running on this computer", which landed me here.

    So i guess with the changes to Terminal Services since 2008, i've got the whole thing fumbled. I just need to have sessions for external connectivity - and I installed the licensing role and imported the CAL's, I just can't seem to utilize them. 

    Wednesday, November 20, 2013 4:36 PM
  • What do you mean by external connectivity? Do you mean internet users on non-domain clients?

    If this is what you are trying to accomplish then you have to 

    Logon to you RDS server

    Open Server Manager and navigate to Remote Desktop Services and click on tasks

    Edit Deployment Configurations and change the RD Gateway name to match your external RDweb URL

    and make sure to change the RD Gateway certificate to match this name also.

    and also make sure that your external name is resolvable from the internet.


    Housam Smadi

    Wednesday, November 20, 2013 7:07 PM
  • Sorry, I was neither accurate nor specific. I don't need non-domain clients to have connectivity, when I referred to external I just meant connections through the RDWeb gateway, which currently hosts an RDP link to the server. All the incoming connections to the server will be from the same domain, I just need to have the gateway manager managing those connections, and utilize CAL's from the licensing server rather than just an RDP connection. I don't currently have that functionality. 

    When troubleshooting I was directed to the Hyper-V role, and perhaps I misunderstood what kind of 'sessions' were going to be utilized and how they are being managed. 

    The RDGateway name is currently listed as the local server [servername].[domain].com
    • Edited by Dforgacs Wednesday, November 20, 2013 7:23 PM
    Wednesday, November 20, 2013 7:18 PM
  • I'm still a little bit confused about your case, I'm not native English speaker.

    Are your domain joined computers can establish a connection to the RDGateway from the internet using the RDWeb link: https://[externalname].[something].com/RDweb ?


    Wednesday, November 20, 2013 7:56 PM
  • Yes, Domain joined computers can establish a connection to the RDGateway with that address. 

    The connection is just an RDP connection into the server, and not a session through the gateway manager. 

    Wednesday, November 20, 2013 8:01 PM
  • Is there any input on why the connections coming in do not pass through the gateway manager, or show in the manager at all?
    Friday, November 22, 2013 8:06 PM
  • Hi,

    Here writing to ensure that, how is everything going? If there is anything I can do to help on this issue, please feel free to let us know.

    Saturday, November 23, 2013 2:59 PM
  • The incoming connections to the server only come in as an RDP connection, and are not connecting to the gateway manager or showing up in the gateway manager at all.

    I don't understand how to create a session for them to connect to, utilizing the CAL's, and controlling them from the gateway manager.

    Monday, November 25, 2013 4:24 PM
  • Hi,

    Firstly sorry for the late reply.

    Here for your issue, I want to check some points with you.
    Have you find any related Event log for your issue?
    Did you check that the authorization policy for RD Gateway is placed properly?

    There are 2 Authorization policies: RD CAPs, RD RAPs. After RD CAP is stored it must be configured correctly to support RD Gateway. Please go through this Best Practices Analyzer for RDS.

    You can use group policy setting to manage the client connections through RD Gateway and also enable the connection through RD Gateway with GPO setting. Please refer this guide below guide for more information.

    1.  What’s new in Windows Server 2012 Remote Desktop Gateway
    2.  Enable Connections Through Remote Desktop Gateway
    3.  Remote Desktop Gateway Manager

    Hope it helps!
    Sunday, December 01, 2013 5:32 AM
  • Hi,

    How is everything going? Could you please tell us the present situation? If you need any further assistance, please let us know.

    Wednesday, December 04, 2013 1:25 AM
  • A second thread started to garnish more results, which for others reference is located here:

    That thread is ongoing, this thread can be terminated.

    Friday, December 06, 2013 2:53 PM