locked
No inbound audio for first 20 seconds of any call RRS feed

  • Question

  • Hi everybody, I'm reaching out for your help with a strange issue we're having!

    Setup is Lync 2010 Enterprise + Standalone Mediation Server with 2 NICs (one routed on telephony subnet) and Aastra MX-one v4.1 sp4 as PSTN gateway. 

    We're having a problem with inbound Enterprise Voice calls. When a call is coming in to the Lync client from PSTN it's rings through just fine, but the receiving end will not hear any audio for the first 20 seconds or so.

    The caller will hear audio from the Lync user fine from the very beginning. 

    When calling out from Lync, audio is fine both ways from start.

    What I've found out so far is:

    1. If I user the Lync 2010 Logging Tool to log the component "MediaStack_RTP" on the Mediation Server, I get a lot of these entries whenever data is transmitted on the RTP stream (ie the PSTN caller is talking)

    Component: (Shared)
    Level: TL_WARN
    Flag: RTP_RECV
    Function: CRtpSessionImpl_c::TransformRecv
    Source: rtprecv.cpp(394)
    Local Time: 01/22/2013-08:00:14.256
    Sequence# : 00000E1B
    CorrelationId : 0x000000001E5B9138
    ThreadId : 0920
    ProcessId : 06EC
    CpuId : 1
    Original Log Entry :
    TL_WARN(RTP_RECV) [1]06EC.0920::01/22/2013-07:00:14.256.00000e1b ((Shared),CRtpSessionImpl_c::TransformRecv:rtprecv.cpp(394))[0x000000001E5B9138]pCBufferStream[0x00000000226F0538] pCRtpParticipantRecv[0x0000000022778038] SSRC:0xD604B775 Seq:5404 PT:8 packet dropped, SSRC in BYE state


    After about 20 seconds these entries will stop, and the RTP stream will be closed and participants removed:

    CRtpParticipantRecv[0x000000001F80E2C0] SSRC:0x0E9B9B59 removed from ByeQ

    A new RTP stream will then be set up with a new SSRC and audio will start to function both ways.

    2. With Wireshark on the Mediation Server, I can see that RTP traffic flows both ways with the G.711 codec whenever someone is speaking. There is, as far as I can see, no difference in the traffic when it's only working one way from when it starts to work both ways after about 20 seconds.

    3. When ringing from PSTN to a Lync extension, I can see the following message in Wireshark: Unknown RTP version 0. A the same time I'm also getting a few ICMP Destination unreachable (Port unreachable). These lines will be present for about half a second when I'm ringing in, but before I pick up the call from my Lync client.

    A few other points..

    - Aastra MX-one doesn't support REFER support so that is not enabled

    - Windows firewall is disabled

    - Static routes are set up on the Mediation Server

    - The Mediation Server NIC on the telephony subnet is not registered with the DNS

    I'll be most thankful for all help and advice on this matter!

    Also, from my readings on similar problems on this and other forums, this could be due to NAT / routing problems. However I found no evidence of that in my logs. How could I verify that?

    Thanks in advance!

    Wednesday, January 23, 2013 10:16 PM

Answers

  • Yep, it was a problem on the PSTN gateway. A firmware upgrade to the IPLU cards solved it.
    • Marked as answer by J.Beckman Friday, February 1, 2013 10:51 AM
    Friday, February 1, 2013 10:50 AM

All replies

  • Another finding, whenever I pick up the call in Lync, I get this log entry:

    Component: (Shared)
    Level: TL_ERROR
    Flag: RTCP_SDES
    Function: CRtpSessionImpl_c::GetRecvParticipant
    Source: rtplookup.cpp(219)
    Local Time: 01/24/2013-09:31:57.972
    Sequence# : 0003B70B
    CorrelationId : 0x000000001F89B138
    ThreadId : 08F4
    ProcessId : 06B0
    CpuId : 0
    Original Log Entry :
    TL_ERROR(RTCP_SDES) [0]06B0.08F4::01/24/2013-08:31:57.972.0003b70b ((Shared),CRtpSessionImpl_c::GetRecvParticipant:rtplookup.cpp(219))[0x000000001F89B138]SSRC:0x1261204F not found

    Thursday, January 24, 2013 8:34 AM
  • I think you PSTN call go through the telephone subnet, try to register the Mediation Server NIC on the telephony subnet with the DNS.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 24, 2013 8:56 AM
  • Hi Liza and thanks for answering.

    From what I've read the second NIC should definately not be registered with the DNS. The second NIC resides on the telephony subnet and a static route has been set up.

    Registering it with the DNS will cause the fqdn to point to the wrong IP

    Thursday, January 24, 2013 10:35 AM
  • The times I've seen this it ended up being some incorrect settings on the PSTN gateway. Fixing those fixed the problem. However I have absolutely zero experience with an Aastra MX-1. If the Aastra is officially certified by Microsoft then Aastra has to have an integration document available - it is part of the certification requirements. Get a copy of that document and review it line-by-line with your configuration.

    Have you visited Lync News lately? All of the latest Lync news, articles, and tips collected in one giant aggregator. http://lyncne.ws

    Tuesday, January 29, 2013 11:01 PM
  • Yep, it was a problem on the PSTN gateway. A firmware upgrade to the IPLU cards solved it.
    • Marked as answer by J.Beckman Friday, February 1, 2013 10:51 AM
    Friday, February 1, 2013 10:50 AM