locked
The URL you have requested is not associated with any application RRS feed

  • Question

  • I am trying to add a link to our intranet that requires authentication via UAG before the page will be displayed. I have an intranet site that UAG allows access to users from the Internet. The intranet site is accesable internally with out using UAG. User clicks the link, they are prompted by UAG to login, they enter info and then an error is displayed that the URL you have requested is not associated with any application.

    UAG URL - https://portal.domain.com/
    Intranet URL - http://connect.domain.com/
    Link requiring authentication - https://portal.domain.com/hr/uinfo.aspx

    Mark

    Tuesday, April 20, 2010 8:33 PM

Answers

  • I resolved the problem by creating a Manual URL Replacement

    To do this I clicked Configure next to "Configure Trunk Settings", then clicked the Portal tab

    Under "Manual URL Replacement", clicked "Add"

    Entered the following...

    URL: /hr/uinfo.aspx
    TO URL: left blank
    Type: Rerouting
    Server name: connect.domain.com
    Port: 80
    Use SSL: unchecked

    Mark

    Thursday, April 22, 2010 10:55 PM

All replies

  • What errors do you get in the Web Monitor event logs?

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    • Marked as answer by Erez Benari Tuesday, April 20, 2010 9:23 PM
    • Unmarked as answer by Mark Kilpatrick Thursday, April 22, 2010 10:47 PM
    Tuesday, April 20, 2010 9:19 PM
  • Is the 'https://portal.domain.com' URL fo the UAG portal or the published URL of the application?  Which application type did you publish your intranet as?  Application Specific Hostname or Portal Hostname?

    As Jason suggested, errors from Web Monitor would be very helpful.

    David

    Wednesday, April 21, 2010 2:30 AM
  • The error in Web Monitor event logs is A request from source IP address xx.xx.xx.xx(my workstation IP) on trunk pbportal; Secure=1 for server N/A failed because the requested URL (/hr/uinfo.aspx) contains an invaild signature and cannot be resolved.

    Mark

    Wednesday, April 21, 2010 12:55 PM
  • It is for the portal but I have set the initial application to be connect and unchecked the Use portal frame.It is a Web type application.

    The default URL will load fine. Any link clicked works as will including the /hr/uinfo.aspx because it is rewritten with the /uniquesigddf9087091f47bda9cd0cfaad4d5ab677c043753cd4fe8a336ed0b82482bce72/uniquesig0/hr/uinfo.aspx

    The issue is we want people to be able to go to https://portal.domain.com/hr/uinfo.aspx with out the long URL.

    Currently the link is /hr/uinfo.aspx which gets rewritten to https://portal.domain.com/uniquesigddf9087091f47bda9cd0cfaad4d5ab677c043753cd4fe8a336ed0b82482bce72/uniquesig0/hr/uninfo.aspx.

    This works fine for users who access the site from the outside as the only way to get to the site is via UAG which requires authentication.

    The real issue is users on the inside go to http://connect.domain.com/ and do not authenticate. The /hr/uinfo.aspx needs the user to be authenticated to work so we want to change the URL from /hr/uinfo.aspx to https://portal.domain.com/hr/uinfo.aspx with out the /uniquesigddf9087091f47bda9cd0cfaad4d5ab677c043753cd4fe8a336ed0b82482bce72/uniquesig0/

    Is there a way to get this to work? Much like https://portal.domain.com/owa/ works.

    Or is there a way to use the https://portal.domain.com/hr/uinfo.aspx URL link on the http://connect.domain.com/ site and have UAG process the link with the UniqueSignature?

    Mark

    Wednesday, April 21, 2010 1:09 PM
  • I resolved the problem by creating a Manual URL Replacement

    To do this I clicked Configure next to "Configure Trunk Settings", then clicked the Portal tab

    Under "Manual URL Replacement", clicked "Add"

    Entered the following...

    URL: /hr/uinfo.aspx
    TO URL: left blank
    Type: Rerouting
    Server name: connect.domain.com
    Port: 80
    Use SSL: unchecked

    Mark

    Thursday, April 22, 2010 10:55 PM