locked
How to get back the control of cursor again during the installation of OS (such as WinXP, Windows 2000 server) in Virtual Server or Hyper V environment RRS feed

  • Question

  • Hi ALL,

    I know it is a simple question but it is very annoying for me when the cursor is out of focus during the installation of Operating System. No matter how hard I try, I cannot get the cursor control back. Are there any hot key that allow me to get the cursor control during the guest OS are installing. 

    TIA

    M C
    Friday, January 16, 2009 3:57 AM

Answers

  • Hi,

    According to your description, you can't click the button in the VM like "OK" or "Next', right?? If you mean this, I guess you are using Remote Desktop to control the Hyper-V machine. In Remote Desktop, you can use mouse to control the VM until you install the Integrated Services. You can use keyboard (use Tab key to switch the option from one to one) to control the procedure of the installation.


    If I misunderstand your concern, please feel free to let me know.


    Best regards,
    Vincent Hu

    • Edited by Vincent Hu Friday, January 16, 2009 11:52 AM
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by Vincent Hu Tuesday, January 27, 2009 2:11 AM
    Friday, January 16, 2009 9:15 AM
  • Here is a list of the keyboard shortcuts you can use to facilitate mouseless navigation: http://support.microsoft.com/kb/126449
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by BrianEhMVP Tuesday, January 27, 2009 4:35 PM
    Friday, January 16, 2009 11:44 AM
  • You must be installing WindowsXP. While using RDP to access the Host partition.

    It is the only OS that does this, and it truely is highly annoying.

    the problem is that you have to send an Alt+Tab combination, and your local system always keeps intercepting it.

    You need Alt+PageUp or Alt+PageDown to bring focus.

    The secret decoder ring is here:
    http://blogs.msdn.com/mwilbur/archive/2007/02/24/remote-desktop-shortcut-keys.aspx

    Brian Ehlert (hopefully you have found this useful)
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by BrianEhMVP Tuesday, January 27, 2009 4:35 PM
    Friday, January 16, 2009 3:53 PM

All replies

  • Yes, use CTRL + ALT + Left Arrow to release the mouse.

    You can change the release key to something else by going into the Hyper-V Settings in the Hyper-V Server Manager. It's defined in the User section under Mouse Release Key.
    • Proposed as answer by John Paul Cook Friday, January 16, 2009 4:05 AM
    • Unproposed as answer by M Chan Friday, January 16, 2009 6:20 AM
    Friday, January 16, 2009 4:05 AM
  • Hi,

    The problem is that during the OS installation, I cannot use the mouse for input. Now there is a dialog box prompting for "OK" and the dialog is out of focus. I cannot activate the windows using any combination of keys including Ctrl-Alt- Left arrow key.

    Any advise are welcome.

    TIA

    MC
    Friday, January 16, 2009 6:19 AM
  • Hi,

    According to your description, you can't click the button in the VM like "OK" or "Next', right?? If you mean this, I guess you are using Remote Desktop to control the Hyper-V machine. In Remote Desktop, you can use mouse to control the VM until you install the Integrated Services. You can use keyboard (use Tab key to switch the option from one to one) to control the procedure of the installation.


    If I misunderstand your concern, please feel free to let me know.


    Best regards,
    Vincent Hu

    • Edited by Vincent Hu Friday, January 16, 2009 11:52 AM
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by Vincent Hu Tuesday, January 27, 2009 2:11 AM
    Friday, January 16, 2009 9:15 AM
  • Here is a list of the keyboard shortcuts you can use to facilitate mouseless navigation: http://support.microsoft.com/kb/126449
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by BrianEhMVP Tuesday, January 27, 2009 4:35 PM
    Friday, January 16, 2009 11:44 AM
  • You must be installing WindowsXP. While using RDP to access the Host partition.

    It is the only OS that does this, and it truely is highly annoying.

    the problem is that you have to send an Alt+Tab combination, and your local system always keeps intercepting it.

    You need Alt+PageUp or Alt+PageDown to bring focus.

    The secret decoder ring is here:
    http://blogs.msdn.com/mwilbur/archive/2007/02/24/remote-desktop-shortcut-keys.aspx

    Brian Ehlert (hopefully you have found this useful)
    • Proposed as answer by Vincent Hu Thursday, January 22, 2009 4:08 AM
    • Marked as answer by BrianEhMVP Tuesday, January 27, 2009 4:35 PM
    Friday, January 16, 2009 3:53 PM