locked
RPC over http issues RRS feed

  • Question

  • Hi,

    We are facing problem in setting up OOO through RPC over http and finding free/busy calender information of users in outlook.Our RPC over http users are behind ISA 2006 Reverse proxy.Last change we did is we had changed NSPI ports on exchange servers (cluster nodes and public folder nodes) from 6001,6002 and 6004 to 7000,7001 and 7002 ports.

    Exchange 2007 with SP2,CCR technology.

    Please help and revert in case any queries.

     

    Friday, September 23, 2011 6:52 AM

Answers

  • Hi Santosh,

     

    Thanks for your update and clarification. 

     

    As you may already know that, both OWA client and Outlook Anywhere client use the same 443 port to connect CAS server. The difference is that, Outlook Anywhere require additional URL to retrieve OOF feature, that is the availability service external url.

     

    Since OOF is working fine in OWA, I believe the connection between CAS server and mailbox server is working fine; so the issue is possibly caused by the external URL—either the incorrect configuration, or the incorrect DNS.

     

    Based on the current situation, my suggestion is:

     

    1.    Run “Get-WebServicesvirtualDirectory |FL” make sure you have setup the external URL for availability service. For more information, refer to:

     

    Configure Exchange Services for the Autodiscover Service (same for Exchange 2007)

    http://technet.microsoft.com/en-us/library/bb201695.aspx

    Default settings for Exchange-related virtual directories in Exchange Server 2007

    http://blogs.technet.com/b/exchange/archive/2008/02/01/3404755.aspx

     

    2.    Run "Test Email Autoconfiguration" on the problematic Outlook client that is connecting via Outlook Anywhere. Make sure the external URL is returned successfully.

     

    Refer to: http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx .

     

    3.    Launch IE in the problematic Outlook client, try to access the external URL returned by “Test Email Autoconfiguration”. Make sure you are able to resolve it and login.

     

    Let me know if there is anything unclear or if you have any further questions on this thread.

     


    Fiona
    • Proposed as answer by Fiona_Liao Thursday, September 29, 2011 10:12 AM
    • Edited by Fiona_Liao Thursday, September 29, 2011 10:15 AM
    • Marked as answer by Fiona_Liao Friday, September 30, 2011 7:03 AM
    Thursday, September 29, 2011 10:12 AM

All replies

  • Hi,

    The network ports you mentioned are used to connect mailbox server and the GC server not the CAS server. To setup OOF and finding free/busy, the autodiscover service and the availability service should be available for the problematic clients.

    Two questions:

    1. Can you setup OOF in your LAN (Both the RPC over http connection by pass the ISA and RPC connection)?
    2. Can you setup OOF in OWA with the problematic user account?

    Besides, please run the following two tests on the problematic Outlook client (when the issue occurs):

    1. Test Email AutoConfiguration (see

      http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx )

    2. Remote connectivity test (see https://www.testexchangeconnectivity.com/)

    let me know the test outcome. thanks.


    Fiona
    • Proposed as answer by Fiona_Liao Tuesday, September 27, 2011 3:46 AM
    • Unproposed as answer by Fiona_Liao Tuesday, September 27, 2011 3:46 AM
    Monday, September 26, 2011 3:45 AM
  • Thanks Fiona for your response.I would like to add few more things for your reference.

    1) Internally all users are able to check free/busy infomation for all users also they can able to set OOO for their accounts.

    2) Externally all users are able to set OOO for their outloook.

    We have publish exchange through Reverse proxy using ISA 2006 SP1.

    I can see requests coming for RPC sessions on reverse proxy but somehow they are denying hits for CAS server on changed NSPI ports.Is their any bindings related to NSPI ports change.

    Already I had tried Test Email Auto configuration on serveral machines but no prob found.I will again fo through provided links and revert at the earliest.

     

     

     

    Monday, September 26, 2011 6:49 AM
  • Then what is the current issue if  you are able to set OOO in both internally and externally? Are you trying to map the network port? If so, please refer to http://support.microsoft.com/kb/270836;

    If it is related to fireall configuration, please go ahead to TMG forums here: http://social.technet.microsoft.com/Forums/en-US/Forefrontedgegeneral/threads. Your understanding would be appreciated.  


    Fiona
    • Edited by Fiona_Liao Monday, September 26, 2011 9:37 AM
    • Proposed as answer by Fiona_Liao Tuesday, September 27, 2011 3:47 AM
    • Unproposed as answer by Fiona_Liao Thursday, September 29, 2011 10:12 AM
    Monday, September 26, 2011 9:35 AM
  • make sure your firewall permit ,  if the port range cover ports 7000,7001 and 7002 .

    thanks

    Ryan

    Monday, September 26, 2011 10:04 AM
  • Did you check the ISA log?

    Monday, September 26, 2011 1:36 PM
  • Then what is the current issue if  you are able to set OOO in both internally and externally? Are you trying to map the network port? If so, please refer to http://support.microsoft.com/kb/270836;

    If it is related to fireall configuration, please go ahead to TMG forums here: http://social.technet.microsoft.com/Forums/en-US/Forefrontedgegeneral/threads. Your understanding would be appreciated.  


    Fiona


    Additional information for your reference:

    http://technet.microsoft.com/en-us/library/bb331973.aspx.

    Let me know if you have any other questions on this thread. thanks.


    Fiona
    Tuesday, September 27, 2011 6:01 AM
  • Sorry for misguiding you in my above reply.

    Please read as

    2) Externally all users are able to set OOO for their OWA webmail and facing problem while setting the same through outlook.

    We did checked ISA logs which are showing failed connections to CAS server on NSPI ports as they are still hitting old NSPI ports.

    Which we had changed from 6001,6002 and 6004 to 7000,7001 and 7002.

     Please note we did changed NSPI ports on exchange mailbox servers and public folder store server.

    Please let us know is there something missing to change it on CAS servers.We referred below links for changing NSPI ports.

    http://support.microsoft.com/kb/270836

    Regards,

    Santosh Dalvi

     

     

    Wednesday, September 28, 2011 4:51 AM
  • Hi Santosh,

     

    Thanks for your update and clarification. 

     

    As you may already know that, both OWA client and Outlook Anywhere client use the same 443 port to connect CAS server. The difference is that, Outlook Anywhere require additional URL to retrieve OOF feature, that is the availability service external url.

     

    Since OOF is working fine in OWA, I believe the connection between CAS server and mailbox server is working fine; so the issue is possibly caused by the external URL—either the incorrect configuration, or the incorrect DNS.

     

    Based on the current situation, my suggestion is:

     

    1.    Run “Get-WebServicesvirtualDirectory |FL” make sure you have setup the external URL for availability service. For more information, refer to:

     

    Configure Exchange Services for the Autodiscover Service (same for Exchange 2007)

    http://technet.microsoft.com/en-us/library/bb201695.aspx

    Default settings for Exchange-related virtual directories in Exchange Server 2007

    http://blogs.technet.com/b/exchange/archive/2008/02/01/3404755.aspx

     

    2.    Run "Test Email Autoconfiguration" on the problematic Outlook client that is connecting via Outlook Anywhere. Make sure the external URL is returned successfully.

     

    Refer to: http://technet.microsoft.com/en-us/library/bb397225(EXCHG.80).aspx .

     

    3.    Launch IE in the problematic Outlook client, try to access the external URL returned by “Test Email Autoconfiguration”. Make sure you are able to resolve it and login.

     

    Let me know if there is anything unclear or if you have any further questions on this thread.

     


    Fiona
    • Proposed as answer by Fiona_Liao Thursday, September 29, 2011 10:12 AM
    • Edited by Fiona_Liao Thursday, September 29, 2011 10:15 AM
    • Marked as answer by Fiona_Liao Friday, September 30, 2011 7:03 AM
    Thursday, September 29, 2011 10:12 AM
  • By the way, regarding the ISA log about  which are showing failed connections to CAS server on NSPI ports as they are still hitting old NSPI ports, did you setup a firewall between the CAS server and other servers like Mailbox server, GC/DC?
    Fiona
    Thursday, September 29, 2011 10:33 AM
  • Sorry for delayed reply.

    I will check above steps and revert.Between CAS server and Mailbox server or GC/DC there is not firewall.

    External client request will hit ISA R PRoxy then through ISA rules it will come to CAS server and from CAS server to mailbox server.

    But somehow we are getting hits on old NSPI ports.

     

     

    Wednesday, October 5, 2011 11:31 AM
  • Hi,

    I have got few clue on above issue,recently We have changed our primary email addresses for all users from patni.com to igatepatni.com.Using patni.com we are able to set up OOO from externally through outlook also able to access free/busy information for other users through outlook but same thing not working for igatepatni.com primary email address.

    Please let us know what are the changes we need to do in autodiscover configuration.

    Please revert ASAP.

    Thanks!

     

     

    Wednesday, October 12, 2011 1:02 PM
  • Hi Fiona,

    Please reply me for my above query.awaitng for prompt reply.

    Thanks!

     

     

    Monday, October 17, 2011 7:40 AM
  • Hi Santosh,

    Sorry for the delay reply. I suggest you add an external DNS record for  igatepatni.com. and then test the url below from external network:

    https://igatepatni.com/autodiscover/autodiscover.xml; or https://autodiscover.igatepatni.com/autodiscover/autodiscover.xml.

    This is because Outlook uses the SMTP suffix to find Autodiscover service from external network.

    Of course making sure your this new domain is included in your Certificate.


    Fiona
    Monday, October 17, 2011 8:07 AM