none
Skype for Business user does not show up when searching by first or last name RRS feed

  • Question

  • I have a Skype for Business user that does not show up when searching in the S4B client. When her first name is entered in the search box the result is: "We couldn't find an exact match. Try refining your search." The result is the same when her last name is entered. However, entering her SIP address "username@company.com" returns the correct result with her picture, presence, etc. I can't find anything in her AD account or in her Lync account that is different from other users who can be searched for. This seems to be system wide. None of our users, including our front desk operators, can search for her--which makes it hard for the operators to transfer calls to her.

    I've tried deleting Galcontacts.db, galcontacts.db.idx, CoreContact.cache, ABS_<sign-in name>.cache, Mfugroup.cache, PersonalLISDB.cache, and PresencePhoto.cache and resyncing. That didn't help.

    Any ideas what might be going on?

    Lync Server 2013 on-prem. Skype for Business 2016 clients.

    Thursday, July 27, 2017 9:13 PM

All replies

  • Hi KLaffoon,

    Based on your description, did you mean that the issue just appear on the specific user in your environment?

    If the issue only appeared on the specific user, please try to disable the user in Lync server side, re-enable the user then test again.

    You could also try to run the command line in Lync server management shell to update address book:
    Update-CsAddressBook

    Hope this reply is helpful to you.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 28, 2017 2:07 AM
    Moderator
  • Thanks for the suggestions, but neither of those helped. I also deleted the user from Lync and re-added her. That didn't help either. I'm still not able to search for her by name. And, yes, it is just one specific user.
    • Edited by KLaffoon Monday, July 31, 2017 9:19 PM
    Monday, July 31, 2017 9:19 PM
  • You can compare user attribute

    run the command : get-csuser

    Thursday, August 3, 2017 8:18 AM
  • We faced the similar issue and we found the user was hidden from address list, after un-hiding it worked.
    • Proposed as answer by Ramesh Epili Tuesday, June 4, 2019 12:11 PM
    Tuesday, June 4, 2019 12:11 PM
  • This solved our issue too.  Employee was re-hired but someone forgot to unhide the mailbox from the address book when they re-enabled the account.  Thanks Ramesh
    Thursday, August 22, 2019 8:45 PM