locked
UAG - Offline Client Components installer RRS feed

  • Question

  • All,

    As per these articles.

    http://technet.microsoft.com/en-us/library/dd857235.aspx

    and

    http://technet.microsoft.com/en-us/library/ee861162.aspx

    I have Set the OfflineInstaller type to All.

    <siteMapNode url="~/OfflineInstaller.msi?type=All"
        title="$Resources:Resource, 114"
        description="$Resources:Resource, 114" 
        imageUrl="~/images/ToolBar/offlineInstallation.gif"
        DisplayMode="OnlyImage"
        target="_blank" />

    After which I saved the doc, and restarted the server for good measure. The Icon appeared on the toolbar and I could download it successfully.

    However, when I run the OfflineInstaller.msi I get the following error.

    "The installation package could not be opened.
    Contact the application vendor to verify that this is a
    valid windows Installer package"

    Anyone know a fix?

    Wednesday, January 27, 2010 2:52 PM

Answers

All replies

  • Please try to download the installer again to verify that this was not a result of some network fluke. If it still isn't working, inspect it's properties - it should be an MSI file that is 2,964,992 bytes long. If the file you have is significantly different, it's possible that the file was actually an HTML error message page. If so, try to open it with a text editor or a web browser to see what the error actually is (could be access or security-violation).
    Ben Ari
    Microsoft CSS IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Thursday, January 28, 2010 9:41 PM
    • Unmarked as answer by AdrianOConnor Friday, February 12, 2010 7:26 PM
    Thursday, January 28, 2010 9:40 PM
  • Hi

    Its not a network fluke the OfflineInstaller does not work.  You get a .msi file that is 5.09 meg in size and when you try to run it you get the error that AdrianOConnor quoted.

    The file is a binary file therefore, you can't see its contents in Notepad.

    Its on UAG 4.0.1101.0 BETA Evaluation

    Is there any other way we can extract the files for an offline installation.  We urgently need these files for a Win 7 client.

    There seem to be no setup.exe in the utils/OfflineClientSetup folder.  Although there are lots of cab files there.

    And is IAG 2007 SP3 coming out?

    Thanks

     

    Thursday, February 4, 2010 11:48 AM
  • Have we any update on this yet?
    Friday, February 12, 2010 7:27 PM
  • Can you use any of the WhlClientSetup.*.msi packages in ~\von\portalhomepage?

    Any one of them should be directly accessible through a URL such as:

    http://uag.treyresearch.net/uniquesigf4da7c5a6b3cf9fcca12d47f013b9c5b/uniquesig0/CRMPortalHomePage/WhlClientSetup-All.msi

    • Marked as answer by Erez Benari Wednesday, February 17, 2010 11:54 PM
    Saturday, February 13, 2010 3:15 AM
  • Hi Appserver,

    By downloading the files to a USB I could run them on the Client PC's.

    The Offline Installer above it still broken though.

    Thank you however for your work around, at least I can move forward now.

    Cheers
    Wednesday, February 17, 2010 11:04 AM