Cannot refresh table - test connection works fine but refresh gives "We couldn’t refresh the connection. Please go to existing connections and verify they connect to the file or server." error.


  • I'm having some difficulty updating a table in my powerpivot data model. The data for the table is stored in a local excel file; if I go to Existing Connections select the connection and do a test then everything is successful. When however I try to refresh that particular table I get the following error:

    "We couldn’t refresh the connection. Please go to existing connections and verify they connect to the file or server."

    In the past I had this and it was an authentication issue, the files are stored on SharePoint and I wasn't logged in to Sharepoint - I have however checked this and it can't be the issue because I have other tables linked to other excel files in the same location that are refreshing without issue. Can anyone think of what may be causing it?

    I have even tried creating a new local excel with the same data, added it to the data model and then tried a refresh and I I get exactly the same issue. 

    Are there any known issues with refreshing data from an Excel file if, after the initial import, you add columns to the table in the excel file I was wondering if this might contribute?


    Wednesday, July 24, 2013 8:12 AM


All replies

  • Hi Maracles,

    Thanks for your post.

    From your description, I tried to reproduce this issue on my test environment. However, everything is fine for me. Could you please post the specific version of SQL Server PowerPivot for Excel?

    You can try to use a trace file to troubleshoot errors in PowerPivot. If this issue still persists, please try to reinstall SQL Server PowerPivot for Excel to see if this helps.

    For more information, please see:
    PowerPivot Options & Diagnostics Dialog Box:
    Using a Trace File to Troubleshoot Errors in PowerPivot:

    Best Regards,  

    Elvis Long
    TechNet Community Support

    Sunday, July 28, 2013 1:52 AM
  • I had similar problem. The error message is misleading and it is happening due to using wrong table name or you dropped some table which is referring in SQL query / view /stored  procedures.   I troubleshoot it and fixed it. Please follow the following steps.

    1. Refresh each sheet manually without using refresh all option. By doing this you will find exactly which sheet has issue in refreshing.

    Once you get the error while refresh, try to execute Sql script or stored procedure and fix the issue.

    Once you have fixed the issue, You can use refresh all option and it should work without any issue.


    Sanjay Singh

    • Proposed as answer by ashmueli Thursday, November 14, 2013 8:41 PM
    Sunday, August 25, 2013 11:23 PM
  • Hi Maracles,

    Take a look at the source data, if your spreadsheet or database table is empty, you will get this error message.

    Chuy Rojas (MCP)

    Wednesday, December 04, 2013 8:14 PM
  • The most common is a variation in the table being refreshed. If you're trying to refresh a PowerPivot table and the data source table has either more or less columns, this error can pop up.

    Alternatively , make sure that the fields/columns being refreshed are of the same data type. If you try to update a numeric PowerPivot column with sting/varchar/text, this error will occur.


    1. In PowerPivot, add or remove columns in the same location (order) as the data source table (might work)

    2. Cross check the column types in PowerPivot and make sure the data types are the same format in both your data source and PowerPivot. You can change the format/data-type in PowerPivot by highlighting the column and changing the Data Type (in the middle of the home menu). Once you've checked or changed these, try again. This worked for me.

    Monday, January 19, 2015 10:43 PM
  • Hi Sanjay,

    Excellent solution to a very murky problem - thank you.

    Especially seeing that there are no error messages which the user receives - you merely get asked to re-enter your user password and if anything there is a complaint about the connection and not the individual query which may be causing the refresh failure.


    James Hinton

    Wednesday, February 08, 2017 8:39 AM
  • Hello Maracles,

    I just worked through this same error and I wanted to mention how I worked it out.

    The table that was causing the error on Refresh was what used to be called a linked table from Excel. It was the one side of 4 relationships. I had a ton of Calc Columns so I didn't want to drop and re-add.

    I was able to update if I removed the joins and then added them back after the refresh.

    Hope this helps some folks.

    John Donnelly

    • Edited by J_Donnelly Friday, March 16, 2018 11:15 PM
    Friday, March 16, 2018 11:15 PM