none
Reports RRS feed

  • Question

  • Hi

    I've created a few project in PWA and now want to see some reports relating to them (and ultimately build my own) I browse to Reports -> PWA Reports then select on, Project Overview but the report is empty, none of the Enterprise Projects I have created and can see in the Project Center are visible. 

    Can you help?

    Thanks

    Paul

    Tuesday, July 25, 2017 10:47 AM

All replies

  • Paul --

    There are two things you need to do:

    1.  You must publish each of your enterprise projects to push the data into views and reports in PWA.

    2.  You need to refresh the data in the report before you can see it.  Open the report, then click the Data pick list button in the upper right corner of the page, and select the Refresh All Connections option.

    You should now be able to see the data from your projects in the report in PWA.  Hope this helps.


    Dale A. Howard [MVP]

    • Proposed as answer by Julian Bönigk Wednesday, July 26, 2017 6:06 AM
    Tuesday, July 25, 2017 9:56 PM
    Moderator
  • Dale is right. Make sure you Refresh the OData Feeds.

    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, July 26, 2017 6:06 AM
  • Thanks guys

    Tried that but i get an error:

    

    I haven't changed anything 'out of the box' the projects don't have any custom fields etc.

    Hope you can help.

    Kind regards

    Paul


    PMO Getech

    Thursday, July 27, 2017 7:29 AM
  • Hello Paul, which security role do you use? Per default, only Administrators, Portfolio Managers and Portfolio Viewers have the permission to refresh OData feeds. Please ensure that you have access to the ProjectData feed: https://yoururl.com/sites/yourpwa/_api/ProjectData -> If the tables appear in your IE, the problem is related directly to the reports.

    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Sunday, August 6, 2017 6:59 PM
  • Hi Julian

    Thanks for the reply. I am a Global Admin for O365, I can't see where I set the Admin roles for Project Online though (are they different?).

    If I amend the link with our details it doesn't seem to work. 

    Hope you can help.

    Regards

    Paul



    PMO Getech

    Thursday, August 17, 2017 8:55 AM
  • Hi Paul,

    so it seems that you have a security problem, because you don't have an admin role in your PWA, yet. To assign yourself an admin role do the following:

    • Project Permission Mode

    Open your PWA and go to PWA settings. In the section "Security" click on "Manage Users". Click on your user or add a new user and assign the security group "Administrator".

    • SharePoint Permission Mode

    Open your PWA and click on share. Invite yourself as "Administrator".


    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Saturday, August 19, 2017 10:29 AM
  • Hi Julian

    In my PWA settings I don't see a 'Security' section. Any suggestions?!

    Thanks

    Paul


    PMO Getech

    Monday, August 21, 2017 8:45 AM
  • Paul --

    From your description, your Project Online system is set to SharePoint Permissions mode.  You will need to change it to Project Server Permissions mode so that you can see the various security Groups and change permissions as needed.  Most users find that SharePoint Permissions mode does not offer the granularity needed to manage user permissions effectively.  Hope this helps.


    Dale A. Howard [MVP]

    Monday, August 21, 2017 10:08 PM
    Moderator
  • You will find this option in the SharePoint Admin center of your O365 tenant, if you click on Project Web App. Check out this link: https://project-brain.com/2016/05/26/pwa-administration-within-office-365/

    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Tuesday, August 22, 2017 6:10 AM
  • OK, so I changed the permissions as above and now I am locked out! I am a Global Admin and have the Project Online licence in my settings but when I try and access MS Project PWA I get an error saying I don't have a licence.

    Can you help? Not sure what has changed, the licence appears valid.

    Thanks

    Paul


    PMO Getech

    Monday, September 4, 2017 11:17 AM
  • Can you please verify that you are the site collection admin of the PWA within O365? If so, go to the PWA settings and select "Manage Users" -> assign yourself the security group "Administrator".

    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Monday, September 4, 2017 11:33 AM
  • Yes, done that. Still get the same error above.

    Hope you can help.

    Kind regards

    Paul


    PMO Getech

    Monday, September 11, 2017 12:29 PM