locked
Office365 Calendar Permissions User grayed out in Scheduling Assistant RRS feed

  • Question

  • two users

    User1 is seen normally as I would expect, in both 'shared calendar' and 'scheduling assistant'

    Permissions are

    PS C:\> Get-MailboxFolderPermission -identity “User1:\Calendar”
    
    FolderName           User                 AccessRights                                           SharingPermissionFlags
    ----------           ----                 ------------                                           ----------------------
    Calendar             Default              {Reviewer}
    Calendar             Anonymous            {None}

    User2 is seen normally in 'shared calendar' but shows grayed out in /scheduling assistant

    Permissions are

    PS C:\> Get-MailboxFolderPermission -identity “USER2:\Calendar”
    
    FolderName           User                 AccessRights                                           SharingPermissionFlags
    ----------           ----                 ------------                                           ----------------------
    Calendar             Default              {Reviewer}
    Calendar             Anonymous            {None}
    Calendar             Bob                  {Reviewer}
    Calendar             Willis               {Reviewer}
    Calendar             Frank                {Reviewer}

    I am at a total loss :(  The way the permissions are, I would expect user1 to be broken, but in reality, User2 is.  So confused.

    I know I can force fix User2 with explicitly adding my user to the permissions, but the problem is across many users and many calendars.  How can I get User2's calendar to be visible (busy times) in 'scheduling assistant'


    BlankMonkey

    Thursday, November 1, 2018 12:10 AM

All replies

  • Hi BlankMonkey,

    Do you mean free/busy information doesn't show in Scheduling Assistant? Does it show as following (grey out)?

    From the description, multiple users cannot see the busy information of User2, right?

    Does this issue only occur on Outlook client? Please check whether free/busy information show correctly on OWA. This helps determine whether this issue is related with server permission or Outlook client.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, November 1, 2018 6:00 AM
  • Thank you fro the reply!

    Correct, this effects multiple users.  In my testing case, all can't.

    So, the 'grayed out' is NOT like what you have highlighted, but it is the slanted lines like the ones at the very bottom of your snapshot I think..  Like \\\\\\\\\

    This is in the Outlook and OWA.

    Recall, I can 'fix' this by explicitly adding the permissions per user.  but as soon as I revoke them, it goes back to the way it was.


    BlankMonkey

    Thursday, November 1, 2018 4:57 PM
  • Hi BlankMonkey,

    According to my research, the primary scenario this happens in is if the user being added to the meeting is in Exchange Online and has time blocked on their calendar with availability as "Working Elsewhere". Please refer to the detail in this link to see if this is your case.

    Another possible reason is that Outlook is using cached browser information. We can clear the offline cache to see the result. To do this, please open Internet Explorer and go to Tool  > Internet Options. Under General tab, click Delete button.

    Hope this is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.




    • Edited by Perry-Pan Friday, November 2, 2018 8:37 AM
    • Proposed as answer by Perry-Pan Monday, November 5, 2018 8:24 AM
    Friday, November 2, 2018 1:39 AM

  • Just check if this issue has been solved.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, November 6, 2018 6:05 AM
  • Hi BlankMonkey,

    Have you found the fix? How is this issue?

    If you get the solution, you could also share it here so that it will benefit other users a lot.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, November 8, 2018 6:43 AM