locked
Printer spooler will not stay running RRS feed

  • Question

  • I work in a K-8 district that services around 350 computers. We also service a number of printers of which we run through print management in windows server 2008 R2. However, we've recently had a problem with the print spooler stopping and remaining stopped until being manually started again, only to have the spooler stop shortly after. Specifically, we've only had this problem in one computer lab that has an HP CP3505 printer and a RICOH SP4100. We have tried a number of problem solving techniques, including (but not limited to):

    -Clearing the C:\windows\system32\spool\printers & C:\windows\system32\spool\drivers

    -setting the recovery steps to "restart the service" in the service properties

    -reinstalling the latest PCL5 drivers for the printers on our server

    -diving into regedit to make sure everything checks out over there

    -restarting the printer

    -installing latest windows updates

    -taking ownership of the spoolsv.exe (we gave both specific users and everyone access, no avail)

    -reimaging the computers (without sysprep, this is next in our list of things to try)

    We cannot shake this problem, and the lab is heavily used. Anyone have any clue to what may be going on?

    Thursday, May 29, 2014 7:56 PM

All replies

  • If this issue also persists server side, consider using driver isolation to mitigate the impact of bad drivers on the spooler service.

    Clientside, iIt could be there are conflicting drivers installed.

    On the client, in device and printers, select a printer, in the top bar select print server properties and from the drivers tab remove all unneeded drivers.


    MCP/MCSA/MCTS/MCITP


    • Edited by SenneVL Friday, May 30, 2014 8:17 AM
    Friday, May 30, 2014 8:17 AM
  • will try this today. Thank you for the tip. I will post back with results.
    Friday, May 30, 2014 3:31 PM
  • This happened when i tried to remove unneeded drivers:

    Failed to remove driver Brother HL-5170DN. The specified printer driver is currently in use. 
    Failed to remove package prnbr001.inf. Driver package is in use.

    the Brother printer is not even in use on the computer, just an HP 3505 and the Ricoh. Tried freezing the spooler service and that locked me out of even getting to that menu. i'd submit a picture but apparent my account isnt "verified" (which it should be, i clicked the link in the email they sent me)


    

    Tuesday, June 3, 2014 2:49 PM