none
Windows Defender - "you'll need a new app to open this windowsdefender" error on server 2019 RRS feed

  • Question

  • Some malware got past Windows Defender on a couple of our servers, we have managed to clear it off and get it running properly, but on one server it seems to be working (the services are OK and it is blocking occasional malware according to the SCCM endpoint reports) but you cannot open the app up without getting a "you'll need a new app to open this windowsdefender" error.

    Does anybody have any idea how to fix this. I've found various generic guides about this error but all appear to be for windows 10 which has the full app store. This is a server 2019 machine and all the app store repair processes seem to do nothing.

    Monday, January 14, 2019 1:47 PM

All replies

  • this wont be helpful but i have the same problem.

    Thursday, January 31, 2019 8:48 PM
  • As mentioned here: https://answers.microsoft.com/en-us/insider/forum/all/you-need-a-new-app-to-open-this-windowsdefender/80434440-8dee-4f1f-b5b8-43e638ad8ee0, you need to open Defender settings firstly from Cortana search (Start menu search). After that trick you can access Defender settings page as usual.

    This is a bug.

    Tuesday, February 19, 2019 11:37 AM
  • Still doesn't work when i use cortana :/ any help ?
    Saturday, March 2, 2019 8:55 PM
  • Appeared on Lenovo ideapad 320  just returned from warranty hard disk replacement/10 install.  Defender working according to system/about.  7 gen core i5-7200U.  Can't fix so far. 320 updated to 1809.  Snip has moved message informed.   Defender works fine on Lenovo Flex 5  7 gen core i5-7200U 10/1803. Fix ideas? Flex 5 windows.iso reinstall fast.  Portable apps running from sdhc card required only making short cuts.  windows.iso possible fix option open. 
    Monday, March 4, 2019 10:47 PM
  • As mentioned here: https://answers.microsoft.com/en-us/insider/forum/all/you-need-a-new-app-to-open-this-windowsdefender/80434440-8dee-4f1f-b5b8-43e638ad8ee0, you need to open Defender settings firstly from Cortana search (Start menu search). After that trick you can access Defender settings page as usual.

    This is a bug.

    That DOES NOT fix the problem. Does anyone else have a fix? Thank you

    Saturday, March 9, 2019 1:03 AM
  • Ok, I fixed it

    Use this code to register all AppX packages

    $BasePath = Get-Content .\appx.list $BasePath | % { $Path = $($_).Trim() Add-AppxPackage -Register -DisableDevelopmentMode "$Path\AppXManifest.xml" }

    Save folder list to file appx.list

    I get this folder list from working installation

    Content of appx.list

    C:\Windows\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy               
    C:\Windows\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy                          
    C:\Windows\ImmersiveControlPanel                                                        
    C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy                                 
    C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy                           
    C:\Windows\PrintDialog                                                                  
    C:\Windows\SystemApps\Windows.CBSPreview_cw5n1h2txyewy                                  
    C:\Windows\SystemApps\Microsoft.Windows.XGpuEjectDialog_cw5n1h2txyewy                   
    C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy                       
    C:\Windows\SystemApps\Microsoft.Windows.PinningConfirmationDialog_cw5n1h2txyewy         
    C:\Windows\SystemApps\Microsoft.Windows.PeopleExperienceHost_cw5n1h2txyewy              
    C:\Windows\SystemApps\Microsoft.Windows.OOBENetworkConnectionFlow_cw5n1h2txyewy         
    C:\Windows\SystemApps\Microsoft.Windows.OOBENetworkCaptivePortal_cw5n1h2txyewy          
    C:\Windows\SystemApps\microsoft.windows.narratorquickstart_8wekyb3d8bbwe                
    C:\Windows\SystemApps\Microsoft.Windows.CapturePicker_cw5n1h2txyewy                     
    C:\Windows\SystemApps\Microsoft.Windows.AppRep.ChxApp_cw5n1h2txyewy                     
    C:\Windows\SystemApps\Microsoft.Win32WebViewHost_cw5n1h2txyewy                          
    C:\Windows\SystemApps\Microsoft.LockApp_cw5n1h2txyewy                                   
    C:\Windows\SystemApps\Microsoft.ECApp_8wekyb3d8bbwe                                     
    C:\Windows\SystemApps\microsoft.creddialoghost_cw5n1h2txyewy                            
    C:\Windows\SystemApps\Microsoft.BioEnrollment_cw5n1h2txyewy                             
    C:\Windows\SystemApps\Microsoft.AsyncTextService_8wekyb3d8bbwe                          
    C:\Windows\SystemApps\Microsoft.AccountsControl_cw5n1h2txyewy                           
    C:\Windows\SystemApps\InputApp_cw5n1h2txyewy                                            
    C:\Windows\SystemApps\Microsoft.Windows.AddSuggestedFoldersToLibraryDialog_cw5n1h2txyewy
    C:\Windows\SystemApps\Microsoft.Windows.AppResolverUX_cw5n1h2txyewy                     
    C:\Windows\SystemApps\Microsoft.Windows.FileExplorer_cw5n1h2txyewy                      
    C:\Windows\SystemApps\Microsoft.Windows.FilePicker_cw5n1h2txyewy                        

    You can get it like this:

    Get-AppxPackage | Select InstallLocation | Out-file appx.list
    • Proposed as answer by Vladimir_ITTC Thursday, March 21, 2019 7:19 PM
    Thursday, March 21, 2019 7:14 PM
  • For topic starter will be enough this

    Add-AppxPackage -Register -DisableDevelopmentMode "C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml"


    • Proposed as answer by Vladimir_ITTC Thursday, March 21, 2019 7:23 PM
    • Edited by Vladimir_ITTC Thursday, March 21, 2019 9:28 PM topic starter recipe
    Thursday, March 21, 2019 7:23 PM
  • Can someone put the answer above in terms I can understand?  

    In other words, I do not have a clue as to how to implement this fix - please provide step-by-step instructions...

    Thanks...

    Monday, April 1, 2019 8:37 PM
    1. Open PowerShell console as Administrator
    2. Run command:
    Add-AppxPackage -Register -DisableDevelopmentMode "C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml"

    • Edited by Vladimir_ITTC Wednesday, April 3, 2019 6:57 PM Steps :-)
    • Proposed as answer by Juan Durán Sunday, June 30, 2019 3:29 PM
    Wednesday, April 3, 2019 6:56 PM
  • Very nice - worked perfectly!!

    I just didn't know about PowerShell console - still new to Win-10 and learning.  

    Many thanks...

    Wednesday, April 3, 2019 11:39 PM
  • For topic starter will be enough this

    Add-AppxPackage -Register -DisableDevelopmentMode "C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml"


    THANKS!

    This worked (instead of the prior adviced "Cortana Search" Workaround)

    Friday, April 5, 2019 3:34 PM
  • Perfect!!! This fixed my issue. Thank you!!
    Wednesday, April 24, 2019 10:58 PM
  • Thanks!!

    It Worked

    Friday, May 24, 2019 1:11 PM
  • Thanks.  This workaround worked. 

    I don't feel like I should have to do this with a fresh install of Windows.  What has happened to quality control at Microsoft?

    Saturday, June 1, 2019 8:18 PM
  • Thanks - Manage Security is back.

    I find it totally unacceptable that a brand new install of Windows 10 Pro would have it missing or disabled in the first place - very poor form, Microsoft!

    Sunday, July 14, 2019 8:07 AM
  • Thank you very much. This fixed my problem.
    Monday, July 22, 2019 8:39 AM