none
Robocopy not maintaining folder timestamps, but is mainting file timestamps RRS feed

  • Question

  • Hi,

    I'm using the following command:

    robocopy d:\mac\backup m:\ /s /copyall /dcopy:T

    to copy a lot of data from my windows 2008 R2 server to a new Synology NAS. The timestamps on the files are being maintained, but on 90% of the folders timestamps are NOT being maintained (oddly they are being maintained on a small portion). I cannot figure out i there's anything unique about those folders that do maintain timestamps.

    Ideas?

    Thanks,

    Al

    Friday, October 13, 2017 4:53 PM

All replies

  • Hi Al,

    Which timestamp was not maintained for the folders? Date Created or Date Modified?

    Based on the test in my lab, this function works properly. In this case, I recommend you could try again with the latest version in Windows Server 2016 or Windows 10 to see if the issue remains.

    If you need further help, please feel free to let us know.

    Best Regards,
    Albert Ling

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 16, 2017 7:16 AM
  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,
    Albert Ling

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 19, 2017 9:13 AM
  • Hi,

    I am checking how the issue is going, if you still have any questions, please feel free to contact us.

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.

    Appreciate for your feedback.

    Best Regards,
    Albert Ling

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 24, 2017 2:18 AM