none
HIS Compatability with DB2 Versions RRS feed

  • Question

  • What versions of HIS are certified for DB2 v10 and DB2 v11?

    We are currently on DB2 v10 and planning to upgrade to DB2 v11 soon.  Are there any known DB2 compatiblilty issues with HIS 2009, HIS 2010, or HIS 2013?

     

    Monday, June 23, 2014 5:26 PM

Answers

  • We have not stated support for DB2 for z/OS V11 for any of our currently available DB2 Providers. We normally support versions of IBM software (such as DB2) that are supported by IBM when a version of HIS is released. We sometimes add support for newer DB2 versions to previous versions of the HIS data providers if later testing shows no major incompatibilities.

    You may find that most functionality is correct when going against DB2 version that isn't officially supported, but it isn't unusual to run into incompatibilities because of new features/functions added to the newer DB2 versions. Similarly, using newer DB2 provider versions against older DB2 versions can result in incompatibilities mainly because we often add support for new DB2 features that older DB2 versions do not support.

    If you try using any of the current DB2 Providers against DB2 for z/OS V11 and have problems, we may not be able to provide any updates to resolve the issues.

    The Installation Guides included with the HIS releases (and available for download from the Microsoft Download Center) state the supported DB2 versions.

    HIS 2013:

      • IBM DB2 for z/OS V9.1 and V10
      • IBM DB2 for i5/OS V6R1 and V7R1
      • IBM DB2 for Windows, AIX, HP-UX, Solaris, Linux V9.7 and V10
      • IBM Informix IDS V11.7 and V12.1

      HIS 2010

      • IBM DB2 for z/OS V8.1 and DB2 for z/OS V9.1
      • IBM DB2 for i5/OS V5R4 and V6R1
      • IBM DB2 for Windows, AIX, HP-UX, Solaris, Linux V9.1, V9.5, V9.7

      Note: HIS 2010 also supports DB2 for z/OS V10 if you have the current HIS 2010 Cumulative Updates applied as support for it was added after HIS 2010 was released.

      HIS 2009

      • IBM DB2 for z/OS V8.1 and DB2 for z/OS V9.1 to support an SNA LU6.2 or TCP/IP network connection
      • IBM DB2 for i5/OS V5R4 and DB2 for i6/OS V6R1 to support an SNA LU6.2 or TCP/IP network connection
    • IBM DB2 for Universal Database V8.2, V9.1, V9.5 for Windows, AIX, Linux, HP-UX, and Sun Solaris operating systems to support a TCP/IP network
      connection

    Thanks...


    Stephen Jackson - MSFT

    Monday, June 23, 2014 7:45 PM