none
W-10 Forcing EDGE on me, Will not allow change in defaults

Answers

  • I installed Windows 10 on multiple systems, and on every one of them I changed form Edge to a different browser (Chrome or Firefox) without a problem. And neither the Anniversary - nor the Creators update changed this.

    One the one hand you write:
    "No browser shows in defaults"
    but then:
    you list Chrome, Internet Explorer and Edge.

    Just for clarification: when you search with Cortana, all links will be openend in Edge, regardless of your default browser. Perhaps this is what you are experiencing?
    • Marked as answer by Micrometeor Tuesday, May 2, 2017 9:05 PM
    Wednesday, April 12, 2017 3:34 PM
  • Thanks for your response.

    No browser was shown as the default, but the three browsers were listed. When I tried to change the defaults there it wouldn't select anything.

    I did get it to change today when I went down to the lower selections and selected change by file type.

    It worked!!!! Chrome no shows as my default. 

    I un-installed Cortana as it was trying to take over everything in my desktop

    Thursday, April 13, 2017 8:32 PM

All replies

  • What have you tried?

    Settings > System > Default Apps and the list on right the Browser option? If not that below that, Choose default applications by file type and Choose default application by protocol?

    Wednesday, April 5, 2017 10:04 PM
  • Hi,

    What's your environment, workgroup or domain?

    Generally, if you want to change the default browser, make it:

    If it's Windows 10 1607 or previous version, Settings -> System ->Default apps-> Web browser, change another browser you want.

    If it's Windows 10 1703 version, Settings ->Apps->Default apps->Web browser, change Microsoft Edge to another browser you like.

    If you cannot change from there, let us know the exact error message.

    Meanwhile, if it's domain joined computer, please consider the group policy cause.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 6, 2017 8:42 AM
    Moderator
  • W10-1607

    Home environment with less than 10 users

    Thanks for the responses: But when I do as above nothing happens to change it; No browser shows in defaults, just + Choose a Default

    with Microsoft Edge

           Recommended for Windows

           Google Chrome 

           Internet Explorer

    listed. But when I click on anything... NOTHING Changes

    Note: I haven't clicked on EDGE

    No error message or default shows

    I sure want my W7 Pro Back!

    Mike



    Friday, April 7, 2017 4:06 PM
  •   Have you installed any other browsers? Microsoft only gives you Edge by default. If you install another browser such as Chrome or Firefox you can set it as your default browser.


    Bill

    Saturday, April 8, 2017 10:27 AM
  •   Have you installed any other browsers? Microsoft only gives you Edge by default. If you install another browser such as Chrome or Firefox you can set it as your default browser.


    Bill

    Chrome has been my default since about Chrome V6! Edge took Chrome Default away with latest updates.

    I don't get much time to check this forum often with all the spring activities.

    Mike

    Monday, April 10, 2017 5:18 PM
  •   Have you installed any other browsers? Microsoft only gives you Edge by default. If you install another browser such as Chrome or Firefox you can set it as your default browser.


    Bill

    Chrome has been my default since about Chrome V6! Edge took Chrome Default away with latest updates.

    I don't get much time to check this forum often with all the spring activities.

    Mike

    W-10 Forcing EDGE on me, Will not allow change in defaults

    Is anybody else having this problem????

    Mike

    Wednesday, April 12, 2017 1:50 PM
  • I installed Windows 10 on multiple systems, and on every one of them I changed form Edge to a different browser (Chrome or Firefox) without a problem. And neither the Anniversary - nor the Creators update changed this.

    One the one hand you write:
    "No browser shows in defaults"
    but then:
    you list Chrome, Internet Explorer and Edge.

    Just for clarification: when you search with Cortana, all links will be openend in Edge, regardless of your default browser. Perhaps this is what you are experiencing?
    • Marked as answer by Micrometeor Tuesday, May 2, 2017 9:05 PM
    Wednesday, April 12, 2017 3:34 PM
  • Thanks for your response.

    No browser was shown as the default, but the three browsers were listed. When I tried to change the defaults there it wouldn't select anything.

    I did get it to change today when I went down to the lower selections and selected change by file type.

    It worked!!!! Chrome no shows as my default. 

    I un-installed Cortana as it was trying to take over everything in my desktop

    Thursday, April 13, 2017 8:32 PM
  • Hi,
    Was your issue resolved?

    If yes, please mark the helpful reply as answer in order that other community members could find the helpful reply quickly.

    If no, please reply and tell us the current situation in order to provide further help.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 24, 2017 8:15 AM
    Moderator
  • Thanks for your response!! It made me look for further steps to fix this.

    When I had a couple minutes I went lower in the settings and discovered another way to change the default, selected Chrome as browser and it worked.

    Thanks for making me look at this again.

    Yes I uninstalled Cortana on my desktop

    Tuesday, May 2, 2017 9:05 PM
  • Hi,
    Was your issue resolved?

    If yes, please mark the helpful reply as answer in order that other community members could find the helpful reply quickly.

    If no, please reply and tell us the current situation in order to provide further help.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Yes my issue was resolved. Thanks to all for your jogging of this Old post-stroke brain!
    Tuesday, May 2, 2017 9:07 PM