none
Queued email to wrong connector. How to redirect RRS feed

  • Question

  • We are migrating from 2003 to 2010 exchange. We had a connector between a Faxmaker server and our 2003 server.  For some reason, the connector stopped working when we moved users to the new server.  I creatied a new send connector to the server and now all new faxes are being sent out as expected, but I have 21 faxes stuck in the queues.  Is there a way to get these to be reprocessed so they will go out the new connector and not the default smtp connector?
    Tuesday, August 7, 2012 4:57 PM

Answers

  • Where are the messages stuck? On the Exchange 2003 server or the 2010 server?

    If Exchange 2010, restarting Transport should force Exchange to reprocess them.
    If Exchange 2003, then restarting the SMTP Server Service should force them to be reprocessed.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Tuesday, August 7, 2012 5:25 PM

All replies

  • Where are the messages stuck? On the Exchange 2003 server or the 2010 server?

    If Exchange 2010, restarting Transport should force Exchange to reprocess them.
    If Exchange 2003, then restarting the SMTP Server Service should force them to be reprocessed.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Tuesday, August 7, 2012 5:25 PM
  • They are on the 2010 server.  They appear to be in the ougoing default SMTP connector and should have gone through the faxmaker connector instead.  If I stop and start the HT will they re-evaluate the connector?  If I tell it to retry, it looks like it's trying to send to an internet server and failing.  The faxmaker connector takes all mail and redirects it to smart host (Faxmaker server) locally...
    Tuesday, August 7, 2012 6:16 PM
  • On Tue, 7 Aug 2012 16:57:52 +0000, Ron_Gladhill wrote:
     
    >We are migrating from 2003 to 2010 exchange. We had a connector between a Faxmaker server and our 2003 server. For some reason, the connector stopped working when we moved users to the new server. I creatied a new send connector to the server and now all new faxes are being sent out as expected, but I have 21 faxes stuck in the queues. Is there a way to get these to be reprocessed so they will go out the new connector and not the default smtp connector?
     
    On which machine are the messages enqueued? If it's the 2003 server
    you can try this:
     
    http://support.microsoft.com/kb/279616
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, August 7, 2012 6:25 PM
  • I'm thinking I may just Kick them back with NDR and have the users resubmit them from their sent items.  Should then flow through correct connector.  I think I was just over-thinking this one!  Would be nice if there was a way to take a mail from one connector queue and send it to another...
    Tuesday, August 7, 2012 6:44 PM
  • On Tue, 7 Aug 2012 18:44:51 +0000, Ron_Gladhill wrote:
     
    >I'm thinking I may just Kick them back with NDR and have the users resubmit them from their sent items. Should then flow through correct connector. I think I was just over-thinking this one! Would be nice if there was a way to take a mail from one connector queue and send it to another...
     
    If the messages are on the 2003 server the registry modification is
    easy to do and quick to try.
     
    Bouncing the messages is certainly an alternative, but users aren't
    usually as on-the-ball as you'd like them to be. :-)
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, August 7, 2012 10:09 PM
  • They are on the 2010 server.  They appear to be in the ougoing default SMTP connector and should have gone through the faxmaker connector instead.  If I stop and start the HT will they re-evaluate the connector?  If I tell it to retry, it looks like it's trying to send to an internet server and failing.  The faxmaker connector takes all mail and redirects it to smart host (Faxmaker server) locally...

    If the Send connector selected by the routing component of the categorizer is deleted or disabled, the configuration change is detected during the message delivery phase. This causes all messages in the queue to be categorized again.

    I suggest you disable defult smtp connector, restart Exchange transport services to have a try.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Wednesday, August 8, 2012 10:16 AM
    Moderator