none
Unable to Backup the DPM 2010 Server using RoboCopy RRS feed

  • Question

  • I want to make a backup of our DPM Server.  I followed the steps outlined in: http://technet.microsoft.com/en-us/library/bb795753.aspx

    1. I'm running DPMBackup -db followed by DPMBackup -replicas

    2. I'm connecting a 500GB external USB drive as N: to the system.

    3. Running the command:  ROBOCOPY "C:\Program Files\Microsoft DPM\DPM\Volumes\ShadowCopy" N: *.* /MIR

     I'm ending up with Access Denied errors and no backups.

    New File               1.0 m        MyFileName.ldf
    2010/12/10 03:03:02 ERROR 5 (0x00000005) Copying File C:\Program Files\Microsoft DPM\DPM\Volumes\ShadowCopy\File System\vol_0b64
    413b-8ba3-402b-9ed9-4656bbed811b\2a707ace-919f-41ca-96ae-d8264c4667bd\Full\MSSQL2008\LOGS\MyFileName.ldf
    Access is denied.
    Waiting 30 seconds... Retrying...

    I'm logged on to the server with a Domain Admin account.  Do I need additional rights?   I didn't have this problem with DPM2007.

    Bob

    Friday, December 10, 2010 9:15 AM

Answers

  • Yes.  I just found a ROBOCOPY command line option /B for "Backup Mode".

    /B (backup mode) will allow Robocopy to override file and folder permission settings (ACLs).

    It's copying great now.

    Bizarre. I've spent over a month of off-on searching for this.  I finally post a question and the answer shows itself 5 minutes later. Ha!

     

    • Marked as answer by Bob Duffett Friday, December 10, 2010 9:47 AM
    Friday, December 10, 2010 9:47 AM

All replies

  • Are you running the command using "Run as admin"?
    Friday, December 10, 2010 9:41 AM
  • Yes.  I just found a ROBOCOPY command line option /B for "Backup Mode".

    /B (backup mode) will allow Robocopy to override file and folder permission settings (ACLs).

    It's copying great now.

    Bizarre. I've spent over a month of off-on searching for this.  I finally post a question and the answer shows itself 5 minutes later. Ha!

     

    • Marked as answer by Bob Duffett Friday, December 10, 2010 9:47 AM
    Friday, December 10, 2010 9:47 AM