none
Mapped drives not showing

    Question

  • Hello 

    We use Group Policy Preferences to map a number of drives to our users. All was working fine but now not all are not showing in the Computer window. Some users will get a drive but other will not. 

    Running a GPResult we see that the drives are getting mapped same if we run a RSOP.MCS. We have also looked through the Event Log on both the client and servers and again cannot find anything out of the ordinary. Last week we remade the GPO from scratch, went through all Share, NTFS settings and user group membership, still no luck. 

    Any ideas would be fantastic as we are fast running out of ideas. 

    Thank you 

    Monday, August 08, 2016 11:00 AM

All replies

  • Hi,
    Please make sure that the problematic computers are rebooted for times to take effect the GPP and User Access Control is turned off on the problematic computers.
    And please check if the reconnect option is selected in the GPP.
    In addition, in my experience, you need check if some other policies or logon scripts are configured to delete mapped drive from problematic computers.
    Regards,
    Wendy

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, August 09, 2016 3:07 AM
    Moderator
  • Hello 

    We have now turned of UAC on a few machines to try this out. 

    Also looking through the rest of the GPOs there are no scripts or other polices to do with mapped drives so fairly sure that that is not the problem. 

    I will get back soon if this works or not. 

    Thank you 


    Ben Fletcher

    Tuesday, August 09, 2016 11:00 AM
  • Still no luck, seems to be happening less but still have the problem. Also users connecting over a VPN are now suffering from the same problem.

    Ben Fletcher

    Thursday, August 11, 2016 7:47 AM
  • If you are filtering on user security groups you better read this:

    Who broke my user GPOs?


    Rolf Lidvall, Swedish Radio (Ltd)

    Thursday, August 11, 2016 9:08 AM
  • Unfortunately, still no change. Starting to run around in ever decreasing circles. Managed to find out when it is happening, when a user moves from one site to another or logs on over the VPN. Users that stay in the same site do not seem to be effected.

    Thank you


    Ben Fletcher

    Tuesday, August 16, 2016 8:01 AM
  • Hi Ben,
    Please try manually mapping the drive to see if it is works.
    In addition, as far as I know, some of the Group Policy Preference items, for example Drive Maps, are processed in the foreground. It means they will get processed only when the user is logging in interactively and when connected to corporate network. This very useful feature finds its limitation when the scope is expanded to support remote users connecting with VPN client software or when laptop users resume from standby on corporate network.
    In order for the Group Policy Preference Drive Maps items to run, you could have a try to update/add the registry value “NoBackgroundPolicy” to “0”. The registry value is located under:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonGPExtensions\{5794DAFD-BE60-433f-88A2-1A31939AC01F}
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 19, 2016 1:46 AM
    Moderator
  • Hi,
    I am checking to see if the problem has been resolved. If there's anything you'd like to know, please don't hesitate to ask.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 22, 2016 9:52 AM
    Moderator
  • Helo

    I have applied the NoBackgroundPolicy to a few users. My fingers are crossed

    Thank you
    Ben


    Ben Fletcher

    Monday, August 22, 2016 3:00 PM
  • Hello

    Seems to work for some users, think I need to look over the permisions of the registry as not all users can apply these settings. Will let you know.

    Thank you
    Ben


    Ben Fletcher

    Tuesday, August 23, 2016 2:55 PM
  • Hello

    Still no luck. Checked out the permisions on the registry and got the change apllying. However users are still not getting there drives mapped.

    Thank you
    Ben


    Ben Fletcher

    Wednesday, August 24, 2016 2:50 PM