none
DPM 2010 - System State and BMR Failures RRS feed

  • Question

  • I am unable to run a successfully run a protection on the System State or the Bare Metal Recovery on a remote Windows2008 R2 print server. The sync job will run for hours and hours and then fail with this error message:

    DPM cannot create a backup because Windows Server Backup (WSB) on the protected computer encountered an error (WSB Event ID: 517, WSB Error Code:  0x800704D4). (ID 30229 Details: Internal error code: 0x809909FB)

    I discovered that the remote protected server does NOT have the required \windowsimagebackup folder created when I install the WSB service. I have now created it, but the sync job still fails. What did I do wrong and can I fix it now by simply uninstalling WSB and reinstalling it ? Will that setup the required folder ?

    Wednesday, May 11, 2011 12:55 PM

Answers

  • This seems to have resolved the issues: uninstall WBS and then reinstall WBS and then manually run a BMR backup to the local data drive.
    • Marked as answer by tgoetzman Monday, May 16, 2011 7:16 PM
    Monday, May 16, 2011 7:16 PM

All replies

  • Hi,

     

    Can you do a system state backup using WSB or does that too fail? If WSB doesn't work either, you might try uninstalling and reinstalling the WSB feature and if WSB still fails troubleshoot the errors generated when the WSB system state job fails.

     

    Thanks,

    Marc

    Wednesday, May 11, 2011 1:34 PM
    Moderator
  • We tried that, but my DPM 2010 console machine does not have sufficient disk space available because the System State and BMR data requirements are so huge.

    Wednesday, May 11, 2011 1:38 PM
  • Hello,

    What Marc meant was to bypass DPM altogether and use Windows Server Backup on the target server to test the functionality of backing up the system state.

    If the WSB feature is installed on that server open up a command prompt and type: Wbadmin start systemstatebackup -backuptarget:c:

    Does this succeed?

    Thanks
    Shane
    Wednesday, May 11, 2011 2:02 PM
  • That fails - my DPM 2010 console machine does not have sufficient disk space available, but I believe we have the root cause figured out now:

    I am using a prebuilt ISO Ghost image to build these servers (provided by a coworker).
    The image has WBS installed, but of course at the time of the build the data drive does not exist.
    The \windowsimagebackup folder does not exist.
    DPM can’t create the files it needs because until I create the folder it has no target.
    On one server I manually created the missing folder and it is fine.

    On a second it repeatedly fails.

    I think I will have to reinstall WBS. 

     

    Thursday, May 12, 2011 7:31 PM
  • This seems to have resolved the issues: uninstall WBS and then reinstall WBS and then manually run a BMR backup to the local data drive.
    • Marked as answer by tgoetzman Monday, May 16, 2011 7:16 PM
    Monday, May 16, 2011 7:16 PM