none
AutoLogon Will not Work

    Question

  • Currently am deploying an image of win 10 Pro. It installs all the applications, syspreps, then reboots in OOBE. From there I select the Language (time / location) and then proceed to join the machine to our Azure AD. After that finalizes and logs into the user, I proceed to change the reg keys 

    HKLM:\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

    DefaultUsername - to the username

    DefaultDomainName - depending on local user or Azure user

    AutoAdminLogon - set to 1

    ADD - DefaultPassword

    It just does not restart into any user. Tried a local user and the Azure user. Tried multiple ways just reg edit, also using autologon.exe (sysinternals), Nothing seems to work. 

    I then decided what would happen if I Un-Azure Domain Join it. Do that, change the Keys, works first time no issue. Re-Join back to Azure and It works no problems after that as well. Seems to be an issue with just an Initial Domain Join from OOBE. I tried comparing registries to see if anything sticks out, but I cannot find what makes the difference here. Any help or insight would be awesome.

    PS - if this needs to go into a different Forum / category, just let me know.

    Thursday, March 30, 2017 11:57 PM

All replies

  • Hi,

    Your registry configurations are correct.

    In general, we use the following configurations:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

    AutoAdminLogon = 1

    ForceAutoLogon = 1

    DefaultUserName = username

    DefaultPassword = password

    Also, try to download and run sysinternals tool directly to see the result.

    https://technet.microsoft.com/en-us/sysinternals/autologon.aspx

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 31, 2017 2:49 AM
    Moderator
  • Besides, there is a link introducing a CMD & UI method to Enable Autologon for Domain-Joined Windows Servers and Workstations, maybe you are interested in

    http://www.expta.com/2008/04/how-to-enable-autologon-for-windows.html

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 31, 2017 2:50 AM
    Moderator
  • I tried with adding the ForceAutoLogon = 1 but that did not work as well. As previously stated, I have tried to use the autologon.exe already, with out success. I can see that the Password Key does get removed, and the autoadminlogon key get reset back to 0. 
    Friday, March 31, 2017 3:11 PM
  • Its an Azure Domain Joined Machine. That check box is not there, and I do not want to log into the local admin account. I need to log in as the Azure AD User.
    Friday, March 31, 2017 3:14 PM