none
PS.debug.js IntelliSense in Visual Studio RRS feed

  • Question

  • I just wanted to know if anyone has successfully managed to get intellisense working with the Project Server json?

    I tried adding a /// <reference to the code and it will not pick up PS.debug.js but I had no issues getting SP.Debug.js to work.

    Tuesday, August 19, 2014 6:58 PM

All replies

  • Hello Spartan422,

    Haven't tried it myself. But the first things that comes to mind is the value of your path. What was the path you used?


    - Dennis | Netherlands | Blog | Twitter

    Friday, August 22, 2014 9:29 AM
  • Hi Dennis, 

    This is the path I am using

    /// <reference path="~/_layouts/15/PS.Debug.js" />

    not sure why it is not working since it works for the following:

     /// <reference path="~/_layouts/15/SP.UI.Dialog.js" /> 

    Wednesday, August 27, 2014 3:58 PM
  • Hello Spartan422,

    What happens if you remove the tilde and use the absolute path? For example (assuming that you installed on C:):
    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\PS.debug.js


    - Dennis | Netherlands | Blog | Twitter

    Thursday, August 28, 2014 8:44 AM
  • Hi Dennis, 

    Tried to use an absolute path but it still didn't work. Here is something interesting though I added a new function in the PS.debug.js file just to see if i can see it in intellisense and that worked. I am confused as to why I can't use the rest of the file.

    Friday, August 29, 2014 4:01 PM