none
Low Resolution in Virtual Machine Connection When Using RDP

    Question

  • Hi all

    I have Hyper-V running on Server 2016. I have installed a Windows 10 1607 client as a guest. When I RDP through to *the server* and open Virtual Machine Connection to the Win 10 guest, the res is crap.

    Why is this and how do I fix it? Please don't give me workarounds, like use RDP to the guest.

    Thanks all

    Low Resolution


    Monday, March 6, 2017 9:13 PM

Answers

  • It is a new feature. 

    They included DPI awarness on the VM connect: https://blogs.msdn.microsoft.com/virtual_pc_guy/2016/06/23/hyper-v-ui-updates-for-high-dpi/

    Numerous people are facing some trouble with it, me included.  I already wasted few hours and found no solution.


    • Marked as answer by MikhailCompo Sunday, March 12, 2017 10:45 PM
    Thursday, March 9, 2017 4:10 PM

All replies

  • If you want the best resolution, use RDP to the guest - even though you say you don't want that, it is a more efficient solution than using RDP to the host and then opening VMconnect. RDP to the guest is a one-step process instead of a two-step process.

    But, if you insist on using the two-step process, configure the VM for enhanced session.  Here is a blog post to help you out - https://blogs.windows.com/windowsexperience/2013/12/05/overview-client-hyper-v-enhanced-session-mode-in-windows-8-1/#OtPAPgAmqRwBcvKz.97


    . : | : . : | : . tim

    • Proposed as answer by Radek Tylich Tuesday, March 7, 2017 3:02 PM
    • Unproposed as answer by MikhailCompo Wednesday, March 8, 2017 6:12 PM
    Tuesday, March 7, 2017 3:00 PM
  • Thanks Tim, but that is not helpful - *specifically* as i said i do not want people to suggest workarounds. This is either a bug, or a setting:

    I have two Hyper-V servers, one is 2012 R2 and one is 2016.

    When I RDP to the 2012 R2 Hyper-V i can view the VMs without any issues, only on the 2016 server does this issue occur.

    I want to know what setting has changed, from Server 2012 R2 to 2016 that causes this.

    Wednesday, March 8, 2017 6:15 PM
  • I understand you were not asking for 'use RDP to the VM' as a solution, and I noted that in my original response.  However, it remains as the recommended way of connecting to virtual machines.  do you experience the same issue when you do use RDP to the guest?

    The engineers are continually updating the interfaces from release to release.  Did you try configuring enhanced session mode on your 2016 server?


    . : | : . : | : . tim

    Thursday, March 9, 2017 4:04 PM
  • It is a new feature. 

    They included DPI awarness on the VM connect: https://blogs.msdn.microsoft.com/virtual_pc_guy/2016/06/23/hyper-v-ui-updates-for-high-dpi/

    Numerous people are facing some trouble with it, me included.  I already wasted few hours and found no solution.


    • Marked as answer by MikhailCompo Sunday, March 12, 2017 10:45 PM
    Thursday, March 9, 2017 4:10 PM
  • It is a new feature. 

    They included DPI awarness on the VM connect: https://blogs.msdn.microsoft.com/virtual_pc_guy/2016/06/23/hyper-v-ui-updates-for-high-dpi/

    Numerous people are facing some trouble with it, me included.  I already wasted few hours and found no solution.


    Thanks for sharing Arnaud, , clearly this is the cause.

    Sunday, March 12, 2017 10:45 PM