locked
Atheros AR5007EG Wireless Network Adapter - With any driver: "The device instance name is invalid" RRS feed

  • Question

  • Hello there,

    I was trying to install various "Atheros AR5007EG Wireless Network Adapter" drivers, with versions ranging from 2007 to 2010, both from the manufacturer and specifically for this computer (a Fujitsu Siemens Esprimo Mobile) and others from here:

    http://www.atheros.cz/atheros-wireless-download.php?chipset=22&system=3
    All of them are for Windows Vista 32bit.


    The computer had previous drivers installed and working, but also had a network problem. In the process of figuring out what was causing it, I tried to install newer drivers to see if that was the problem. It turns out the network problem was due to a different thing that is now fixed (some dependencies of the WLAN Configuration service were turned off), but I'm still stuck installing the new drivers.

    TL;DR:

    However, every time I install new drivers, after install, Windows says that "The device instance name is invalid", regardless of what drivers I install. I even tried to install drivers for different hardware in that slot just to see what it told me and IT STILL gave me the same error. I also tried to uninstall the current driver, checking the box to delete the driver's software, running CCleaner and then deleting "athr.sys" from the Windows/Drivers folder and "oem8.inf" from Windows/Inf as those files were referenced in the driver's properties. The install still gives me the same error.

    The fact that it gives me this error with any driver leads me to believe it's Windows' fault and not the driver's.

    Note: I am translating from the original in Portuguese. "The device instance name is invalid" is the closest/correct translation and seems about right with the info I find online regarding the english version of Vista and how it refers to devices. This (https://groups.google.com/forum/#!topic/microsoft.public.development.device.drivers/yFa_XnlcLJQ) and this (http://finderr.net/windows/pt-PT/O-nome-da-inst%C3%A2ncia-do-dispositivo-%C3%A9-inv%C3%A1lido-/2082573452) also seems to confirm that, though it doesn't help me. It may be that the text is actually different in english Vista but I also searched for driver instead of device or stuff like "The device instance name appears to be invalid" and can't find anything either.

    I also did SFC /SCANNOW a while ago and it found no errors.  I then repeated it again after this problem and this time, SFC found errors BUT it couldn't repair all of them. Here is the CBS log:

    https://www.dropbox.com/s/bayum2rsezxpmre/CBS.log

    Thank you for the help!

    EDIT: The Notebook model is a Fujitsu-Siemens ESPRIMO Mobile V5535 and their support drivers can be found here (after specifying the OS and model):

    http://support.ts.fujitsu.com/download/ShowFiles.asp

    EDIT2:


    The last SFC /scannow scan repaired everything left to repair. The system restore option can't be used because the earliest one still has the (suposedly faulty) drivers installed.

    This computer has a Win Vista serial number, but no CD and the second partition doesn't have any kind of backup. The second partition is empty though. So, as a last resort, if I really don't have a choice, I'll try to do an upgrade install to see if that fixes it and if that still doesn't fix it I'll have to move everything in the users folder to the second partition and format the first which is a bummer :/

    EDIT: Here is the setup.api.log that was inside C:\Windows\Inf and details the instalation process of all the drivers:
    https://www.dropbox.com/s/tyxs1e4r7rxofch/setupapi.dev.log

    I'm still trying to read into that setup.api.log file.

    • Edited by tenac_d Wednesday, April 30, 2014 3:45 PM
    Monday, April 28, 2014 11:40 AM

All replies

  • So, can I assume that the only way to fix this error is to download an iso of Windows Vista, unninstall my service packs, upgrade install Vista, run Vistalizator to change the language to Portuguese and then install Service Pack 1 & 2?

    EDIT: Alright, so I formatted the thing since the driver bug wouldn't give me a break. The details on that can be found searching for the same thread title either on tomshardware or vistaforums if anyone happens to find this looking for the same error.

    I have a real knack for bumping heads with errors that nobody else gets that somehow turn into unfixable bugs. At least if someone else searches for this problem they'll know what to do.

    • Edited by tenac_d Thursday, May 1, 2014 8:26 PM
    Thursday, May 1, 2014 11:07 AM