locked
Unable to edit Excel documents in SharePoint RRS feed

  • Question

  • Our user is unable to edit Excel documents within SharePoint 2007. We use Office 2010 32-bit. There are no error messages. It just does not save. During troubleshooting, noticed 3 SharePoint Add-Ons missing from IE9: Export Database Launcher, OpenDocuments Class, and Stssync Handler. The suggestions were to 1) repair Office 2010, and 2) Uninstall and reinstall Office 2010. Neither option worked.

    Noticed today while troubleshooting that Excel files do not modify at edit, but Word documents do. Checked permissions for the user within the library and she has contributor access. All other users in that user group are able to edit Excel documents. I even deleted and reentered her within the permissions group, but the problem remains.

    Any help would be greatly appreciated. Thank you.

    Monday, June 18, 2012 6:33 PM

Answers

  • Hi accap,

    Here is a similar issue:
    http://social.technet.microsoft.com/Forums/vi-VN/sharepointgeneral/thread/a791f3cd-aa56-4e8e-8837-cecbcfc47308

    Please check out this reply:

    " Finally i figured out the cause to this problem. After having the load balancer data packet we took last week analyzed by the manufacturer and checking the http connections(using FIDDLER) being thrown by client machine to the load balancer, we found out that the problem is caused by the following:

     1) Insufficient setting in the Load Balancer

     2) Change in http method handling between Office 2003 & Office 2010

    Solution:

     Unlike Office 2003, office 2010 seems to be throwing LOCK/UNLOCK method towards the server regularly which is unfortunately NOT SUPPORTED BY DEFAULT  on our  load balancer(OS:Alteon 25.0.0.0). This blog helped me alot:

     http://hongbohe.wordpress.com/2011/05/14/share-point-protocol-support-in-alfresco-3-4-continued/

    After adding the LOCK and UNLOCK http method to the supported method list, i finally got the "read-only" problem to go away and everything is working fine now.

    Hope someone else out there find this solution helpful."

    Thanks,
    Lhan Han
    Thursday, June 21, 2012 10:38 AM
    Moderator