locked
SharePoint portal via Apache reverse Proxy RRS feed

  • Question

  • HI,

    I tried to configure the SharePoint portal access via apache reverse proxy. I have added the below entrys in httpd.conf

    ProxyPass / http://INMUM01EVOSP01/
    ProxyPassReverse / http://evouatportal/

    DNS entries are maintained and porta 80 is open between reversproxy and sharepoint srever.

    Now when I try to access the share point portal with the url http://evouatportal/ I alway get the page can not display. while when i access it with actual url http://INMUM01EVOSP01/ it works.

    Please guide me what can i do to resolve this issue.

     

    Regards

    Amit

     

    Friday, June 3, 2011 6:08 AM

All replies

  • HI Amit,

    Please check with the Alternate access mappings from sharepoint central admin page for the url, and also check with the host header in IIS for the site.

    http://workspace.me/sharepoint/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-1-of-3/

    Regards,

    Raj

    Friday, June 3, 2011 6:25 AM
  • Hi Veera,

     

    Thanks for reply..

    I tried with the alternate access mappings also..... but no luck.

    same page cannot be displayed. I checked with httpwatch ad found it issues message... 401 unauthorized followed by ERROR_HTTP_INVALID_SERVER_RESPONSE

    Do we need to gve any special permission to access the site from reverse proxy.

    Regards

    Amit


    Friday, June 3, 2011 6:36 AM
  • Sharepoint request the authentication for all items in _layouts folder when you are loggedin or  authenticated

    Apache does not send the cookie with the information about the user and password because this folder is defined as a public site and Apache never send the
    credentials for public items.

    for testing create a new web application with the same _layouts virtual directoy and in Apache proxy has configured all the requests to layouts folder to
    this new one web application.

    http://sahelp.sharepointforall.com/FAQ/bconfigure_IIS.html

    http://www.streamreader.org/serverfault/questions/235982/sharepoint-with-apache-reverse-proxy-using-a-subdi

    http://vault.openmonkey.com/articles/2007/08/12/integrating-an-apache-reverse-proxy-and-sharepoint

    Thanks,

    Raj

    Wednesday, June 22, 2011 8:00 AM
  • Good morning, I have a quite similar question. My customer publish its sharepoint sites through apache proxy. The internal site is http://hostname/sites/prevQuadri and it's published as http://sharepoint.xxx.it/sites/prevQuadri

    I have completed the configuration of alternate access mapping on sharepoint and now the site is visibile from internet. You can access page, create view, make searches and so on. Everything ok 

    The problem concerns the POST operation: when I do for example a NewForm.aspx POST request in order to create an item in a custom list I see in Apache Log and also in IIS log that we have 3 post trace message. The first one and the second one have a 401 error code, the last one has 302 but the item is correctly created on my server.

    It seems that when i ask a post operation apache will triplicate my request to IIS: the first two fails and the third is correct. I don't know if it will depends from apache or from Alternate Access Mapping where I have exactly 3 rows for my web application (one as default and two as internet, but this is normal)

    The problem regards post operation with attachment. When I upload a big file using for example Chrome I see my progess bar that starts from 0 to 100%, then restart, then restart again and finally the upload is completed, but sometimes it will finish with internal error because the upload time is too larger. 

    Have you never seen this situation ? 

    I hope someone can help me

    thank you

    emanuele

    Thursday, September 27, 2012 7:44 AM