locked
Deferred Procedure Calls and Interrupts using large amounts of CPU RRS feed

  • Question

  • I'm currently having a problem with my CPU being taken up by DPCs and Interrupts. I've used Process Explorer to locate the problem but can not find a way to fix it. The problem only occurs when running online games in specific (not most applications). I have tried anything that would normally cause a computer to lag in a game such as graphics settings but they don't affect it at all. The lagging is completely random and spikes throughout the day. I have tried updating my drivers and the problem still persists. If anyone can help, it would be massively appreciated.

    System Hardware:

    CPU: AMD Phenom 9850 Quad-Core

    Network Card: RTL8168C(P)

    Sound Card: Sound Blaster X-Fi Xtreme Audio

    Graphics Card: NVidia Geforce 9600 GT

    If I'm missing any important information, please let me know and I'll post it.

    Friday, December 10, 2010 7:49 PM

All replies

  • http://support.amd.com/.  Go here to get the correct choipset and graphics drivers for your chipset and other motherboard components. If the game is on your hard drive, defragment the drive once a week, minimum ! (I do it daily, ...sigh...)


    "http://support.microsoft.com/fixit/default.aspx ". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Saturday, December 11, 2010 7:08 AM
  • I've already updated my chipset, graphics, and motherboard drivers along with pretty much every other device in my computer. I also defragmented my drive when the problem first started, unfortuantely it didn't help. The problem first started about a month ago, and I can't figure out what changes happened at that time. Is there a tool for detecting what piece of hardware is causing the interrupts?
    Saturday, December 11, 2010 12:40 PM
  • I believe I've solved the problem. It appears to be USB overload or something. I disabled my USB headset and it run perfectly fine now.
    Saturday, December 11, 2010 3:29 PM