locked
2012R2 BranchCache Hosted Server not registering the SCP record RRS feed

  • Question

  • We have a hosted BranchCache server that we have moved to a different AD site (after performing testing in an isolated AD site).  We ran the command Enable-BCHostedServer -RegisterSCP to allow automatic discover of the BranchCache server by clients in the same site.

    Running Get-BCStatus shows that the SCP registration is enabled -

    HostedCacheServerConfiguration:

        HostedCacheServerIsEnabled        : True
        ClientAuthenticationMode          : Domain
        HostedCacheScpRegistrationEnabled : True

    But the event log tells a different story -

    Source: BranchCache

    Event ID: 35

    Error message: BranchCache failed to update a service connection point.

    In the details of the event log error it says the following


    ScpUpdateFailedEvent

         

    GUID

         

    ServerDNSName

         

    SiteName

         

    ExpiryTime

    2015-08-14T17:47:37.743Z

         

    ErrorCode

    8240

         

    ErrorMessage

    There is no such object on the server.

    Based on testing, uninstalling and reinstalling the BranchCache features on the server would resolve the issue, however that will also remove the cached files from BranchCache - which in this case is not an option (it has been precached and we don't have the available time or bandwidth to repopulate it.

    Can someone tell me what is going on?

    Thanks.

    Friday, August 14, 2015 12:02 PM

All replies

  • hi,

    perhaps you need to delete the original SCP from AD? 

    get-ADObject -Filter {objectClass -eq 'serviceConnectionPoint' -and Name -eq 'BranchCacheHostedCacheSCP'}

    This will list all your Hosted Cache SCP thingies

    get-ADObject -Filter {objectClass -eq 'serviceConnectionPoint' -and Name -eq 'BranchCacheHostedCacheSCP'}| Remove-Adobject - will delete them ALL - so you might want to filter that list :-)

    Oh, and if you absolutely have to reset BranchCache you WILL lose your content but... you can simply stop the BC service, XCopy out the cache, Reset BranchCache, stop the service again and Xcopy it back again - totally unsupported of course but works!

    Phil


    Phil Wilcock http://2pintsoftware.com @2pintsoftware


    Friday, August 14, 2015 3:08 PM
  • Hi Phil,

    There are no SCP records.  I think that is why it is saying "There is no such object on the server"

    My suspicion is that if you do not initially enabled the hosted cache with the SCP record, then you are unable to do it at a later date - which would be a bit disappointing in my opinion.

    ie.

    1. Run Enable-BCHostedServer. 

    2. Run Enable-BCHostedServer - RegisterSCP

    Monday, August 17, 2015 11:21 PM
  • hi,

    yeah seems this is the case - repro-ed it on my test setup and it fails every time. So if you don't specify -registerscp the first time you run it , it never works. Bit lame!

    The only thing that I can suggest is to either contact MS to see if there's a workaround (such as another way of creating the SCP manually), or Perform a Reset, and then use the BRanchCache Export/Import package cmdlets to re-populate the cache without hitting the WAN..

    OR

    Create the SCP manually using PowerShell - just did a quick test and this worked for me..

    New-ADObject -Name 'BranchCacheHostedCacheSCP' -Type serviceConnectionPoint -OtherAttributes @{serviceBindingInformation="ExpiryTime=01D0DC26C73B6B07;MaxHCProtocolVersionSupported=2;MinHCProtocolVersionSupported=2";serviceClassName="BranchCacheHC";serviceDNSName="WIN10.DOMAIN.LOCAL";serviceDNSNameType="A"} -Path "CN=WIN10,CN=Computers,DC=DOMAIN,DC=LOCAL" 
    Usual disclaimers apply! test it first..

    Phil


    Phil Wilcock http://2pintsoftware.com @2pintsoftware


    • Edited by Phil Wilcock Friday, August 21, 2015 10:34 AM more info
    Friday, August 21, 2015 9:29 AM
  • Yes, we actually tried that, it worked for one server but didn't seem to work for the next server that we tried a couple of days later.  I suspect I know why, but I didn't take the time to test it. 

    My suspicion is that the "ExpiryTime" determines whether a client will read the SCP record or not.  The server seems to try to reset this on the SCP record periodically.  This would make sense as it ensures clients fall back to distributed mode if a Hosted server goes out of action for too long.  Just a theory at this stage.

    Friday, August 21, 2015 12:22 PM
  • Curiously, I've just had this exact same issue and it appears to have been resolved after I added the subnets for the hosted cache servers into AD Sites and Services.

    I had two hosted cache servers on newly created sites exhibiting this behaviour and both have now managed to register their SCPs an hour or so after we configured their subnets.

    I'd be interested to know if anyone else has seen this? I didn't read any pre-requisite about that in the Microsoft Branch Cache documentation, but I suppose setting up AD correctly is a reasonable assumption for them to make :)


    - TYTee [MCTS]

    Thursday, March 10, 2016 5:54 PM
  • Hi TyTee,

    That would make sense.  The SCP record is used to identify the AD site that the BC Host is servicing.  If there is no AD site then it does not have enough information to register a site based SCP record.  A BC Host - where clients are configured for automatic discovery - will only service the clients in the same AD site, so you would want to make sure your clients are also in the same AD site as the BC Host.

    Regards,

    David


    David

    Thursday, March 10, 2016 11:20 PM