locked
Hyper-V Manager - An error occurred while attempting to connect to server - possibly a Failover Cluster/Win 10 issue RRS feed

  • Question

  • When I try to connect to my host servers in Windows 10, I get an error message.  

    I am running 10 pro 10240_x64 as a VM.  It is joined to the domain as my Hyper-V hosts are.  After installing the Hyper-V Management Tools, rebooting and then trying to connect to one of my hosts, I get the same error shown above.

    My account is a member of the domain admins group and the hyper-v console works fine on my Win 8.1 PC.

    Also, I tried using a third party management tool (5Nine Manager for Hyper-V) and it connects just fine.

    As a test, I tried the following.

    1. Created a new VM from Win 8.1 Pro ISO.  Joined it to the domain and logged in as a domain admin.  Added the Windows feature Hyper-V Management Tools.  I was able to connect to my host server just fine.

    2. Created a new VM from Win 10 Pro ISO (build 10240).  Joined it to the domain and logged in as a domain admin.  Added the Windows feature Hyper-V Management Tools.  I got the same error message shown above when I tried to connect to my host servers.

    Both test VMs have the firewall disabled.

    Since both installs are clean and nothing was done other than the steps listed above, I have to assume there is some issue managing Windows 2012 R2 hosts with Windows 10 or some additional steps are necessary that weren't needed in Windows 8.1. 

    I tried Win 10 Hyper-V Manager on another domain and it worked!  The main difference is that the one that won't connect is using Failover Clustering and the other is not.

    I found a MS document that stated "Hyper-V on Windows 10 Technical Preview doesn't support failover clustering".  Even though I'm running the RTM (not one of the earlier preview versions).  https://technet.microsoft.com/en-us/library/dn765471.aspx

    I can't be the only person experiencing this issue.  I had some feedback when I posted this in the TP forum but nothing suggested fixed the issue.

    Thanks,

    Brian

    Thursday, July 30, 2015 3:04 PM

Answers

  • If anyone else has this issue, here is what finally worked for me...

    Make note of your Hyper-V and virtual switch settings, shutdown or migrate your VMs and remove the Hyper-V role, reboot and re-add the role.  Check settings and fix if necessary and re-add your switch once Hyper-V is re-installed.

    When removing the role, you will probably have to use the admin powershell command Remove-WindowsFeature -Name Hyper-V, because the check mark in features GUI was grayed out to remove it there. I was able to re-add it from there.

    Dell ProSupport was useless and a waste of time and Microsoft paid support is $500 per incident, so hopefully this helps someone.

    I found this information here ... https://social.technet.microsoft.com/Forums/en-US/1cc9115d-5fce-4a64-a90f-d3fdc008b861/windows-10-build-10240-managing-hyperv-on-2012-r2-datacenter-cannot-connect?forum=winserverhyperv

    As stated in that article by several people who had problems, do NOT run the MOFCOMP command.  It was not needed and caused other problems.

    Brian

    • Marked as answer by brian7m3 Tuesday, September 22, 2015 2:54 PM
    Tuesday, September 22, 2015 2:52 PM

All replies

  • Hibrian7m3,

    According to the error messages,have you checked the virtual machine management service is running on the promatic machine?

    Have you logged on with the same account?
    We also could try to log on with another domain administrator account to have a check.

    Considering this issue may be related to the failover clustering, we could try to disable it to have a troubleshoot with the powershell "Stop-Cluster".
    Here is a link for reference of using to powershell with failover clusters 
    Failover Clusters Cmdlets in Windows PowerShell
    https://technet.microsoft.com/zh-CN/library/hh847239.aspx

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Saturday, August 1, 2015 2:48 PM
  • Hi MeipoXu,

    Thanks for your reply and suggestions.

    Yes I have checked that the vm management services are running.

    Yes I have tried a different domain admin account.

    I really can't stop the cluster easily as this is a production environment.

    Once again, everything appears to be working fine with our HA cluster and Hyper-V Management on Win 8.1 machines can connect to the host nodes just fine.

    I also tried Enable-WSMaCredSSP -Role Server –Force on the cluster nodes and enable-wsmancredssp -role client -delegatecomputer on the Win 10 client but this did not resolve the issue either.  See https://technet.microsoft.com/en-US/library/mt126130.aspx for further reference to this.   

    There is really nothing special about our Hyper-V HA cluster and as described above, I did a clean install of Win10, joined to the domain and installed the Hyper-V management role and this problem occurred.

    I did the exact same thing with Win 8.1 and everything worked fine.

    I can't understand why no one else seems to be reporting this issue.

    Thanks,

    Brian

                                                            

    Tuesday, August 4, 2015 1:05 PM
  • I have the same issue, your not alone.  It is not a permissions issue as the error message states but I have not been able to fine the solution either.

    I tried this http://serverfault.com/questions/709970/cant-connect-hyper-v-server-2012-r2-after-windows-10-update  to allow remote management through the firewall to no avail.

    Anyone have an answer?

    Myk


    Myk Lougee

    Tuesday, August 4, 2015 3:15 PM
  • Thanks Myk,

    I am trying to upgrade a physical Win7 machine to Win10.  Maybe it's an issue with using a Win10 VM to connect with Hyper-V HA nodes.

    Tuesday, August 4, 2015 3:29 PM
  • Just tried it with a physical computer and still didn't work with High Availability nodes.  It will connect to non HA nodes just like the other computer did.

    Anyone??

    Tuesday, August 4, 2015 7:01 PM
  • If anyone else has this issue, here is what finally worked for me...

    Make note of your Hyper-V and virtual switch settings, shutdown or migrate your VMs and remove the Hyper-V role, reboot and re-add the role.  Check settings and fix if necessary and re-add your switch once Hyper-V is re-installed.

    When removing the role, you will probably have to use the admin powershell command Remove-WindowsFeature -Name Hyper-V, because the check mark in features GUI was grayed out to remove it there. I was able to re-add it from there.

    Dell ProSupport was useless and a waste of time and Microsoft paid support is $500 per incident, so hopefully this helps someone.

    I found this information here ... https://social.technet.microsoft.com/Forums/en-US/1cc9115d-5fce-4a64-a90f-d3fdc008b861/windows-10-build-10240-managing-hyperv-on-2012-r2-datacenter-cannot-connect?forum=winserverhyperv

    As stated in that article by several people who had problems, do NOT run the MOFCOMP command.  It was not needed and caused other problems.

    Brian

    • Marked as answer by brian7m3 Tuesday, September 22, 2015 2:54 PM
    Tuesday, September 22, 2015 2:52 PM
  • Hi Brian,

    I am glad the issue has been resolved and thanks for updating.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, September 23, 2015 1:18 AM
  • I got the same issue on Windows 10 version 1709. My solution was easy, but I tried for a few minutes without success. Instead of using this option:


    Use the second option of "Another computer", then type the Netbios name of the local computer, in my case "Riveratec-Lenovo". It seems the issue is related to the 15 character limit for hostnames. Hyper-V console will try with the shorter name "Riveratec-Lenov", which is not the name of my computer.

    This worked for me.

    Regards,

    Jose Angel Rivera

    IT Consultant.


    Jose Angel Rivera




    • Edited by balboa41 Saturday, February 17, 2018 9:47 PM
    • Proposed as answer by K_T_Physics Monday, August 13, 2018 11:41 AM
    Saturday, February 17, 2018 9:43 PM
  • Hi,

    I had the exact same issue, Turns out the PC name was also too long in my case

    Thanks for the solution.

    Monday, August 13, 2018 11:42 AM