none
DPMRA Error 85 on untrusted workstation RRS feed

  • Question

  • After installing the DPM 2016 Agent on a Non-domain server and attaching it to DPM Server 2016 we are receiving the following error;

    A DPM agent failed to communicate with the DPM service on **** because of a communication error. Make sure that **** is remotely accessible from the computer running the DPM agent. If a firewall is enabled on ****, make sure that it is not blocking requests from the computer running the DPM agent (Error code: 0x5587cf0, full name: ****).

    I have tried the following;

    • Disable the firewall on both the DPM server and the protected server
    • Run SetDPMServer.exe -DPMServerName "DPM-Server-Name" -IsNonDomainServer -Username "UserName" on the protected server and entered the password.
    • Ensured the account is not set to require password change at next logon
    • Ensured the password is set to never expire
    • Run Update-NonDomainServerInfo - PSNAME "Endpoint-Name" -DPMServerName "DPM ServerName" and entered the password as above.
    • Checked for the RPC registry entries as per (They don't exist) https://social.technet.microsoft.com/Forums/en-US/ed09a966-cd72-4cd0-9cc0-3bfe9f802619/dpm-agent-communication-error-id-85-tried-everything?forum=dataprotectionmanager 
    • Can ping between the two servers in question
    • Host file entry is being used provide hostname resolution as DMZ / Seperate DNS in use

    Any help would be greatly appreciated.

    Dan

    Thursday, December 7, 2017 3:23 AM

All replies

  • Hi Dan,

    same problem but authenticating with certificate. 

    How did you solve it?

    Best regards

    Friday, March 2, 2018 1:43 PM
  • For me,

    • Ensured the account is not set to require password change at next logon

    No idea where that could come from in this setup, with the user being auto-generated, and everything working fine for years before that.

    Tuesday, March 24, 2020 1:36 PM