locked
I have no idea what is going on. My problem is with remote service call RRS feed

  • Question

  • Remote service call is constantly using up to 30% of my cpu which stops everything else.
    Friday, December 28, 2018 12:55 PM

All replies

  • Download and run Process Monitor. https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

    Using task manager identify the process id (PID) of the program that is using the cpu. In procmon, set a filter for that PID. Let it run for a bit and then stop tracing. Review the trace to see what files, network and registry calls are being made. 

    Friday, December 28, 2018 3:38 PM
  • Hello,
      
    It would be very helpful if you could provide more background information about your issue.
     
    Is it on your WSUS server side? You could increase the Wsuspool memory size and queue length to enhance the WSUS stability.
     

    1> On your WSUS Server, launch the IIS Manager.

    2> Open Application Pools.

    3> Right click 'WsusPool' and select 'Advanced Settings...'

    4> Increase the WsusPool Private Memory limit x4 times, or set to 0 (unlimited).

    5> Change 'Queue Length' from the default 1,000 to 25,000.
     
    And also do not forget to run the server cleanup wizard regularly.
     
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray


    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 31, 2018 8:11 AM
  • Hello,
     
    Have your issue been solved or it there any improvement? Feel free to feedback.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 1, 2019 8:51 AM