none
SCDPM 2010 Restore DPM Database Issues RRS feed

  • Question

  • Hello,

    I am just starting to setup a DPM 2010 server for deployment. I am in the process of troubleshooting an issue related to restore the dpm server itself in the event of a dpm server failure. I read the technet articles here http://technet.microsoft.com/en-us/library/ff399388.aspx

    I have run the  DPMBackup.exe -db and exported the orginal database. It indicates that all I should have to do to restore the database is to run the DPMsync -restoredb -dbloc <dblocation> command. I keep getting an error and not sure why.

    If I run DPM Management shell as administrator I get following error

    Error ID:465 Unable to close all connections for detaching database. Review Error details and try again.

    Detailed Error: Only user processes can be killed.

    If I run DPM Management shell normally I get a permission error.

    Unhandled Exception: Microsoft.SqlServer.Management.Smo.FailedOperationException: Restore failed for Server 'SERVERNAME\MSDPM2010'.
    ---&;;gt; Microsoft.SqlServer.Management.Common.ExecutionFailureException: An exception occurred while executinga Transact-SQL statement or batch.
    ---&;;gt; System.Data.SqlClient.SqlException: Cannot open backup device 'c:\backuplocation\dpmdb.bak'. Operating system error 5(failed to retrieve text for this error. Reason: 15105).
    RESTORE DATABASE is terminating abnormally.

     

    Any help would be greatly appreciated.

    Thanks

    dallasbr

     

     

    Wednesday, October 19, 2011 2:33 PM

Answers

  • Solution found:

    DPM creates 2 Local SQL accounts. I was unaware that there was two.

    I added permissions to DPMDB.bak for local user accounts MICROSOFT$DPM$Acct & DPMR$"your server name"

    Note: This permision is on the orginal file when you do the export. Where I ran into trouble was I had made a copy of the original and moved it to the desktop. Never thought to check permisions on orginal file. So stupidity caused the issue.

    This solved my issue.

     


    Wednesday, October 19, 2011 6:23 PM