none
Unable to "Run as administrator" RRS feed

  • Question

  • Toshiba A305, came pre-installed with Microsoft Vista Home Premium x64

    I'm unable to do anything that requires administrative privileges.  Open a command prompt with admin rights (using right-click > Run as administrator), open regedit, etc etc.  This all started when I was going to connect to my work VPN from home, and I was unable to open the "connect to" window (left-click on the network icon in the tool tray, click on "connect to" and nothing would happen).  So I tried opening the Network and Sharing Center, and I got a blank window with the error "The page failed to load."  I have not made any changes to this laptop for a few months, these issues came out of the blue.

    Any help would be greatly appreciated.
    Tuesday, September 16, 2008 2:16 PM

Answers

All replies

  • Ran a system restore to 2 days ago as I can't be without a laptop that long, so I'm back up and running w/o any issues.  But I'd still like to hear if anybody else has had any issues with this and how they fixed it (since I didn't install any apps in the last week or so, so I'm not sure what it was that the restore restored).
    Tuesday, September 16, 2008 3:42 PM
  •  

    It seems that you enabled User Account Control (UAC) under Control Panel, User Accounts.

    Thursday, September 18, 2008 3:15 AM
    Moderator
  • But wouldn't that just give me the prompt (while turning the screen dark) saying that I need admin rights to run this app, and ask me if I want to continue or not?  I'm logged in under an account that is part of the administrator group.  And as a sidenote, I turned off UAC after 4 weeks of owning the laptop, so if it did get turned on, I have no idea how it did it heh
    Thursday, September 18, 2008 4:00 PM
  •  

    You can re-enable/disable UAC to check the result if the issue occurs in the future.

     

    This issue can also be related to security settings. You can check the following KB article.

     

    How to reset security settings back to the defaults

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;313222

    Friday, September 19, 2008 6:47 AM
    Moderator
  • But wouldn't the enabling/disabling of UAC require admin rights?

    Thanks for linking the KB article.
    Friday, September 19, 2008 2:12 PM