none
Bitlocker not enabled after deplyoment: Verify %OSSKU% is defined RRS feed

  • Question

  • For some reason when deploying Windows 10 Pro 1703 with MDT 8443 and Windows ADK 1709 Bitlocker wasn't enabled after deployment. When opening ZTIBde.log we can see that the %OSSKU% variable is not set. Anyone noticed this behaviour?

    <![LOG[Microsoft Deployment Toolkit version: 6.3.8443.1000]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[The task sequencer log is located at X:\WINDOWS\TEMP\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[System drive is: X:]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[The deployment method is not using ConfigMgr.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[We are in a Windows PE environment, checking to see if Windows PE supports Offline BitLocker tasks.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Determining if WinPE supports pre-provisioning]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Found Offline BitLocker Tools.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Checking to see if OS supports Offline Bitlocker.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[OS build supports Offline BitLocker.]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Success TPM Enabled]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Success TPM Is Activated]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Success TPM Is Owned]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Success TPM Ownership Allowed]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Check for Ensorsement Key Pair Present = 0]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TpmEnabled: True]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TpmActivated: True]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TpmOwned: False]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TpmOwnershipAllowed: True]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[EndorsementKeyPairPresent: True]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TPM Ownership being intiated with AdminP@ssword (not TPMOwnerP@ssword).]LOG]!><time="06:27:12.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Starting owner authorization process on the TPM]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[TPM is validated.]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[OSDTargetDriveCache was determined earlier : D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Property OSDTargetDriveCache is now = D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Property OSDisk is now = D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Pre-provisioning BitLocker on drive D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[OSDTargetDriveCache was determined earlier : D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Property OSDTargetDriveCache is now = D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Property OSDisk is now = D:]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[About to run command: "X:\WINDOWS\system32\Manage-bde.exe" -on D: -used]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Command has been started (process ID 1040)]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[ZTI Heartbeat: command has been running for 0 minutes (process ID 1040)]LOG]!><time="06:27:19.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Event 41003 sent: ZTI Heartbeat: command has been running for 0 minutes (process ID 1040)]LOG]!><time="06:27:20.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Return code from command = 0]LOG]!><time="06:27:20.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Property IsBDEPreProvisioned is now = True]LOG]!><time="06:27:20.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[ZTIBDE processing completed successfully.]LOG]!><time="06:27:20.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Event 41001 sent: ZTIBDE processing completed successfully.]LOG]!><time="06:27:20.000+000" date="11-17-2017" component="ZTIBDE" context="" type="1" thread="" file="ZTIBDE">
    <![LOG[Microsoft Deployment Toolkit version: 6.3.8443.1000]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[The task sequencer log is located at C:\Users\ADMINI~1\AppData\Local\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[System drive is: C:]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[The deployment method is not using ConfigMgr.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[This script is not currently running in Windows PE]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[FAILURE: False: Verify %OSSKU% is defined.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="2" thread="" file="ZTIBde">
    <![LOG[Bitlocker is only supported on Windows Enterprise or Windows Ultimate or Windows Server]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[ZTIBde processing completed successfully.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[Event 41001 sent: ZTIBde processing completed successfully.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[Microsoft Deployment Toolkit version: 6.3.8443.1000]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[The task sequencer log is located at C:\Users\ADMINI~1\AppData\Local\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[System drive is: C:]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[The deployment method is not using ConfigMgr.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[This script is not currently running in Windows PE]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[FAILURE: False: Verify %OSSKU% is defined.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="2" thread="" file="ZTIBde">
    <![LOG[Bitlocker is only supported on Windows Enterprise or Windows Ultimate or Windows Server]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[ZTIBde processing completed successfully.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    <![LOG[Event 41001 sent: ZTIBde processing completed successfully.]LOG]!><time="15:11:13.000+000" date="11-17-2017" component="ZTIBde" context="" type="1" thread="" file="ZTIBde">
    

    Monday, November 20, 2017 9:06 AM

All replies

  • Is there a Gather step in your State Restore phase? From my understanding, the variable will be set during the Gather step after the first auto logon. Could you post your BDD.log for additional analysis?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Monday, November 20, 2017 11:00 AM
  • Please visit this thread. I noticed this exact error when deploying Windows 10 LTSB

    https://social.msdn.microsoft.com/Forums/sharepoint/en-US/c4da89c8-8951-4fae-8b17-c554d5131de7/mdt-2013-update-2-bitlocker-failure-ossku-not-defined?forum=mdt

    In short, I did this to one of the scripts


    I got it to work by commenting out parts of the ZTIBde.wsf script.. I believe this to be a bug in MDT 2013 Update 2. It does NOT detect Windows 10 LTSB as being an Enterprise edition!!

    '//----------------------------------------------------------------------------
    '//  Check to see if BDE is supported in this OS
    '//----------------------------------------------------------------------------

    '// Check to see if we are running Vista or later and exit if we are not
    '//If iOSCVMajor < 6 Then
    '// oLogging.CreateEntry "Bitlocker is not supported on this version of Windows", LogTypeInfo
    '// Main = iRetVal
    '// Exit Function
    '// Check to see if the SKU supportes Bitlocker
    '//ElseIf not oUtility.IsHighEndSKU then
    '// oLogging.CreateEntry "Bitlocker is only supported on Windows Enterprise or Windows Ultimate or Windows Server", LogTypeInfo
    '// Main = iRetVal
    '// Exit Function
    '//Else
    '// oLogging.CreateEntry "We are running a OS that supports BitLocker", LogTypeInfo
    '//End i
    f
    Monday, November 20, 2017 2:39 PM