locked
Can't send mail via send connector to external smarthost RRS feed

  • Question

  • Hello,

    i use outbound mailhop a service of dyndns.com. I configured the send connector the same way as i did in Exchange 2003. The system uses BasicAuth with TLS. I used it for nearly two year without any problems with Exchange 2003.

    Not i get all the mails back with this error: outbound.mailhop.org #550 Sender verify failed ##

    Then i check the connector from the Management Console i find the Password is empty. Setting it again don't help

    Then i tried to configure the send connector with the Management Shell using the following procedure: $CredentialObject = Get-Credential
    Set-SendConnector "outbound.mailhop.org" -AuthenticationCredential $CredentialObject -AuthMechanism BasicAuthPlusTLS

    That works, BUT the userid now start with a backslash and so is not able to function, seemingly that this time the user is not correct.

    Same good ideas and advice would be very nice.

    Thanks

    Harald

    This is the dump of the send connector:

    Schema                                       : Microsoft.Exchange.Data.Directory.SystemConf
                                                            iguration.SmtpSendConnectorSchema
    DNSRoutingEnabled                 : False
    SmartHosts                                 : {outbound.mailhop.org}
    Port                                              : 25
    LinkedReceiveConnector         :
    ConnectionTimeOut                   : 00:10:00
    ForceHELO                                 : False
    IgnoreSTARTTLS                       : False
    Fqdn                                             :
    RequireTLS                                 : False
    Enabled                                       : True
    ExternallySecuredAsPartnerDomain :
    ProtocolLoggingLevel                : None
    AuthMechanism                          : BasicAuthPlusTls
    AuthenticationCredential           : System.Management.Automation.MshCredential
    UseExternalDNSServersEnabled     : False
    SourceIPAddress                      : 0.0.0.0
    SmartHostsString                      : outbound.mailhop.org
    AddressSpaces                         : {smtp:*;1}
    MaxMessageSize                     : 10MB
    DeliveryMechanism                   : 2
    ConnectedDomains                 : {}
    IsScopedConnector                : False
    IsSmtpConnector                  : True
    Comment                          :
    SourceRoutingGroup               : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers           : {XXXX}
    HomeMTA                                : Microsoft MTA
    HomeMtaServerId                  : XXXX
    MinAdminVersion                  : -2147453113
    AdminDisplayName                 :
    ObjectCategoryName               : msExchRoutingSMTPConnector
    ExchangeVersion                  : 0.1 (8.0.535.0)
    CurrentObjectVersion             : 0.1 (8.0.535.0)
    Name                                        : outbound.mailhop.org
    DistinguishedName                :

    Identity                                   : outbound.mailhop.org
    Guid                                      :
    ObjectCategory                   : hq.local/Configuration/Schema/ms-Exch-Routin
                                       g-SMTP-Connector
    ObjectClass                      : {top, msExchConnector, mailGateway, msExchRo
                                       utingSMTPConnector}
    OriginalId                       : outbound.mailhop.org
    WhenChanged                      : 10.08.2006 22:05:43
    WhenCreated                      : 10.08.2006 22:05:42
    ObjectState                      : Unchanged
    OriginatingServer                : XXXX

    IsReadOnly                       : False
    Id                               : outbound.mailhop.org
    IsValid                          : True

    Thursday, August 10, 2006 8:45 PM

Answers

  • To pinpoint your specific problem here I suggest you set protocol logging to BASIC on your send connector:

    set-sendconnector outbound.mailhop.com -ProtocolLoggingLevel:Basic

    Try to reproduce this, and look under \Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLogs\SmtpSend to see what's going on over the protocol level. If it's being sent through your smarthost (outbound.mailhop.com) because of a mistyped password, you may have to modify how you type in your AuthenticationCredential. Are you specifying the backslash? How do you know that the backslash is there and being used?

    Friday, August 11, 2006 4:21 PM

All replies

  • To pinpoint your specific problem here I suggest you set protocol logging to BASIC on your send connector:

    set-sendconnector outbound.mailhop.com -ProtocolLoggingLevel:Basic

    Try to reproduce this, and look under \Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLogs\SmtpSend to see what's going on over the protocol level. If it's being sent through your smarthost (outbound.mailhop.com) because of a mistyped password, you may have to modify how you type in your AuthenticationCredential. Are you specifying the backslash? How do you know that the backslash is there and being used?

    Friday, August 11, 2006 4:21 PM
  • Ok, thanks

    it helped. And here is the solution. It wasn't the password. It stumbled at my internal mail adress, with ends with .local with is not routable

    I switched Emailadress automatically according to guideline off and set my normal external adress as mainadress and that works fine.

    So thanks again

    Harald

    PS: The blackslash, i didn't specify it, i saw it then i opened the connector again in EMC after setting it with ECS

    Friday, August 11, 2006 10:26 PM
  • Thank you for detailing the steps you took to get here. You found a bug. ;-)
    Saturday, August 12, 2006 2:23 AM
  • Dark Fury:

    I'm having the exact same issue. Can you explain to me how you resolved it?

    Wednesday, August 16, 2006 9:30 PM
  • Ok here is what i did:

    The key is that i use a .local domain on my internal network, so after the installation of E12 all the internal user got mail adresses like firstname@internal_domain.local. And that kind of email adress is not routable so i got the sending of this messages denied.

    First i thought it was the password that i need to use the outbound mailhop service of dyndns. But i switched on basic loging and in the log C:\Programme\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLog\SmtpSend\ i found the entry sever not verified.

    Then i disabled the feature to set the email adress according to email recipient guidelines and set every mailaccount to use the external mailadress i have.

    Hope this help

    Dark Fury

    Wednesday, August 16, 2006 10:00 PM
  • Isit possible to walk me though it? I dont

    know what basic logging is

     

    Wednesday, August 16, 2006 10:44 PM
  • Basic Protocol logging, it saves the SMTP protocol logs in TXT files so you can see the conversation. You can also do network sniffs, however with Exchange 2007 more of the conversation is encrypted by default so it's harder to use that as a diagnostic option.

    To enable protcollogging:

    1) Send connectors: set-sendconnector -ProtocolLoggingLevel:Basic

    2) Receive connectors: set-receiveconnector -ProtocolLoggingLevel:Basic

    3) There's also a boolean on the TransportServer object that allows you to turn on protocol logging for all mail that goes implicitly oubound over SMTP from Hub Server roles. For example for Hub <--> Hub hops the mail doesn't go through a connector you can see / administer. 

    Thursday, August 17, 2006 7:08 AM