locked
Preventing active window from switching automaticly RRS feed

  • Question

  • Hello,

    This is something that has bothered me for ever, not just on windows 7:

    Is there any way to prevent windows from switching from one application to another automaticly???

    Example: I am typing an e-mail (quite rapidly) and a window pops in front of me to warn me of something... obviously, because I type so fast, the space-bar or enter key that I've hit will activate one of the option of the window (either acknowledging or refusing the demand). So, before I know it, the warning has left the screen, and the last phrase that I've typed never got written in my e-mail.

    This is just an example, but there are 100 of situations like this one where I end up typing the wrong information at the wrong place...

    Is there anyway I can disable this? Is there a way to make the window appear, flash in my task-bar, make a notification sound BUT NOT BECOME THE ACTIVE WINDOW, and let me decide WHEN I want to answer the question??? Is there a way for my programs or software to always start in the background??? Yes, I don't mind that Outlook needs 10 seconds to start... but may I do something else while it loads and not be interrupted when it has finished its loading time?

    Well, I hope there is a solution in this multitasking world...

    Thanks.

    Monday, February 15, 2010 10:03 PM

Answers

  • Hi,

    According to your description, you need some settings for it.
     
    I would like stop message or pop-up from Action Center, you can refer to the following article for detailed steps:

    Action Center lets you decide which Windows 7 alerts you see and which you don’t.
    http://www.winsupersite.com/win7/ff_action_center.asp

    Personally speaking, the most annoying active pop-ups when I was typing are Outlook Rules and Alerts. If you are using Microsoft Outlook and would like to avoid overload email notices when are typing important emails, you can consider use a Outlook add-on named Email Prioritizer. It can temporarily pause new email arrival if you are busy.
    http://www.officelabs.com/projects/emailprioritizer/Pages/Default.aspx

    If other application pop-ups to interrupt your typing, you might go to the application’s option panel and check if there is a setting you can select to make the pop-up stay in background.

    PS: If the above steps don’t work, you can use a third-party tool to make your working window always on top.
    Always on Top: Keep Any Window Visible Always: http://www.labnol.org/software/tutorials/keep-window-always-on-top/5213/

    If you meet any problem, pls let me know what program raises the pop-up annoying you.

    Good luck!

    Tuesday, February 16, 2010 10:29 AM

All replies

  • Hi,

    According to your description, you need some settings for it.
     
    I would like stop message or pop-up from Action Center, you can refer to the following article for detailed steps:

    Action Center lets you decide which Windows 7 alerts you see and which you don’t.
    http://www.winsupersite.com/win7/ff_action_center.asp

    Personally speaking, the most annoying active pop-ups when I was typing are Outlook Rules and Alerts. If you are using Microsoft Outlook and would like to avoid overload email notices when are typing important emails, you can consider use a Outlook add-on named Email Prioritizer. It can temporarily pause new email arrival if you are busy.
    http://www.officelabs.com/projects/emailprioritizer/Pages/Default.aspx

    If other application pop-ups to interrupt your typing, you might go to the application’s option panel and check if there is a setting you can select to make the pop-up stay in background.

    PS: If the above steps don’t work, you can use a third-party tool to make your working window always on top.
    Always on Top: Keep Any Window Visible Always: http://www.labnol.org/software/tutorials/keep-window-always-on-top/5213/

    If you meet any problem, pls let me know what program raises the pop-up annoying you.

    Good luck!

    Tuesday, February 16, 2010 10:29 AM
  • Martin, your suggestions are helpful, but do not really apply.  This is a focus issue, something Microsoft refers to as "handling needy applications" that are trying to get your attention or come forward.  I share the original poster's pain about being interrupted by another program will typing.  Sometimes a dialog pops to the screen, and I type a space as part of my sentence, and it inadvertently pops to the front.  Knowing what it is that is interrupting you seems to be treating the symptom, not the real cause.

    Windows XP's TweakUI PowerToy or some registry settings could be used to control how programs take focus (and things such as how many times to flash the taskbar button).  Windows 7 should have similar functionality.  Does anyone know how to configure it?




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Wednesday, February 17, 2010 3:16 AM
  • Hi,

    Thanks for Shawn’s proposal, I notice this kind of issue sporadically occurs. There seems no effective solution for it.

    I can only raise the work around for that such as make the active window always on the top, avoiding lost the focus.
    In addition, the past version Tweak UI can never run on Windows 7, for there is no compatibility mode of XP(sp1).
    I have attempted and failed on my Windows 7.

    But as backup, it seems available, refer to: http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/d8d18244-8cf4-4a7c-ada0-b6efdc798377

    Good Luck!

    Friday, February 19, 2010 10:10 AM