none
Administration site throws CheckSuspiciousPhysicalPath exception

    Question

  • I just installed SharePoint 2010 on my Windows Server 2008 R2 x64 server with SQL Server 2008.

    Everything is installed on this single server, and I configured SharePoint 2010 as described here: http://sharepoint.microsoft.com/blogs/fromthefield/Lists/Posts/Post.aspx?ID=112

    Everything installed correct, and the SQL databases were created.

    But when I try to access the administration site through http://server:47632/_admin/adminconfigintro.aspx, I get the following exception:

      [HttpException]
        at System.Web.Util.FileUtil.CheckSuspiciousPhysicalPath(String physicalPath)
        at System.Web.CachedPathData.GetConfigPathData(String configPath)
        at System.Web.CachedPathData.GetConfigPathData(String configPath)
        at System.Web.CachedPathData.GetConfigPathData(String configPath)
        at System.Web.HttpContext.GetFilePathData()
        at System.Web.Configuration.CustomErrorsSection.GetSettings(HttpContext context, Boolean canThrow)
        at System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow, Boolean localExecute)
        at System.Web.HttpRuntime.FinishRequest(HttpWorkerRequest wr, HttpContext context, Exception e)

    The same error occurs when accessing http://server:47632/.
    Do you have any ideas whats causing this? I haven't been able to find anything about this issue.

    Saturday, April 24, 2010 7:48 PM

Answers

  • After removing SharePoint, TFS and IIS, and reinstalling IIS and SharePoint it works. Strange.
    • Marked as answer by thj Monday, April 26, 2010 5:46 AM
    Sunday, April 25, 2010 10:03 AM

All replies

  • I just tried reinstalling SharePoint 2010 while monitoring the error log. When I run the configuration wizard, the following errors show up in the event log:

    The site /sites/Help could not be created. The following exception occurred: Dependency feature with id 5f3b0127-2f1d-4cfd-8dd2-85ad1fb00bfc for feature 'BaseSite' (id: b21b090c-c796-4b0f-ac0f-7ef1659c20ae) is not installed..

     

    Safe mode did not start successfully. This page has encountered a critical error. Contact your system administrator if this problem persists.

     

    Safe mode did not start successfully. This page has encountered a critical error. Contact your system administrator if this problem persists.

     

    The site /sites/Help could not be created. The following exception occurred: Dependency feature with id 2ed1c45e-a73b-4779-ae81-1524e4de467a for feature 'BaseSite' (id: b21b090c-c796-4b0f-ac0f-7ef1659c20ae) is not installed..

     

    The Execute method of job definition Microsoft.Office.InfoPath.Server.Administration.FormsMaintenanceJobDefinition (ID 59158daa-d0b6-458f-bd0a-7d1d713ac743) threw an exception. More information is included below.

    Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\319280433bd74178b6b1fd945c064698' is denied.

     

    The Execute method of job definition Microsoft.Office.InfoPath.Server.Administration.FormsMaintenanceJobDefinition (ID b3f45215-4d18-44f2-84bd-cc16bc339dd7) threw an exception. More information is included below.

    Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\319280433bd74178b6b1fd945c064698' is denied.

     

    Any ideas?

    Sunday, April 25, 2010 12:03 AM
  • After removing SharePoint, TFS and IIS, and reinstalling IIS and SharePoint it works. Strange.
    • Marked as answer by thj Monday, April 26, 2010 5:46 AM
    Sunday, April 25, 2010 10:03 AM
  • This is an entirely unacceptable answer and should not be marked as so.  MSFT needs to address this please.
    • Edited by Tim Odell Thursday, July 29, 2010 5:56 PM typo
    Thursday, July 29, 2010 5:55 PM
  • Try giving your local\wss_admin_wpg and local\wss_wpg full rights to the directory in the error ('C:\ProgramData\Microsoft\SharePoint\Config\ed76f8ec48174c5abcc89101fa40b70a' ) .  When I checked security that location on my server with that error , I found two unresolved SID in the ACL list

    This was my error

    The description for Event ID '6398' in Source 'Microsoft-SharePoint Products-SharePoint Foundation' cannot be found. The local computer may not have the necessary registry information or message DLL files to display the message, or you may not have permission to access them. The following information is part of the event:'Microsoft.Office.InfoPath.Server.Administration.FormsMaintenanceJobDefinition', '1fb4cf9c-f365-4826-ab43-fdaa5d75a0e6', 'Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\ed76f8ec48174c5abcc89101fa40b70a' is denied.'

    /Colin

    Wednesday, May 29, 2013 4:45 PM