none
Hyper V VM stuck in reboot loop - Server 2012R2

    Question

  • Hello everyone,

    Looking to get some help with one of my VM's currently running on Server 2012 R2. Sometime early yesterday morning (Saturday morning) my Exch VM crashed and got stuck in a reboot loop. Everytime it would try to boot into its install of Server 2012 R2, it would bsod indicating Inaccessible Boot Drive. I am accessing the machine remotely as I can access the Host, and the DC VM without issues. I did the typical shut down and reboot and manual restarts incase it was just a bug. That did not work. I then was entered into the recovery console where I tried last known good configuration, all the different safe modes, etc and still stuck in this boot loop. With that, this morning with a clear head, I took a look at Server Manager on the Host and looked at the Hyper -V Events and saw the following:

    ID 18590

    -Exch12 has encountered a fatal error. THe guest operating system reported it failed with the following error codes: Errorcode 0: 0x7B, Errorcode1: 0x5F16D8D0, Errorcode2: 0xC0000034, Errorcode3: 0x0, Errorcode4: 0x0

    With that said, when I am in recovery console and I tried to enter the command prompt to run say chkdsk or run a repair command, the recovery console has me select my administrator account and asks for a password. I enter my normal password to access the host and all the vm's and it is not accepted. Not sure what is going on here. Also when I look at Hyper-V on the host and look at the Virtual Hard disks, I can see the data file for the VM having issues. When I check disk (on the issue VM) it returns back the Location, File Name, Current File Size and Max Disk Size. With that, I feel the integrity of the data is intact.

    What else can I do to try and remedy this VM issue. Its our exch, so we need to get it operational again.

    I am attempting to restore my Exch VM through a carbonite vm backup, but this is going to be take sometime and I need a more rapid fix to the issue.

    Thank You for the help.
    Sunday, March 19, 2017 4:45 PM

All replies

  • Might try repairing the boot sector;

    bcdboot c:\windows

    https://technet.microsoft.com/en-us/library/hh824874.aspx

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Sunday, March 19, 2017 6:56 PM
  • Hi,
    Are there any updates on the issue?
    You could mark the reply as answer if it is helpful.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 29, 2017 2:18 AM
    Moderator