Unable to Instal MicrosoftML for R Client 3.5.2 on Linux RRS feed

  • Question

  • The issue is that the packages for the full R 3.5.2 client installation do not exist. The documentation says they are supported and the packages should exist, but they do not. The documentation states that the packages should be available for Redhat 6, Redhat 7, SLES 11, Ubuntu 14.04, and Ubuntu 16.04, but none of them contain all 3 packages (and some are even missing packages for 3.4.1 and 3.4.3 so downgrading to an earlier version is not possible). Since none of Microsoft’s package repositories include all 3 packages, switching to a different operating system also does not solve the problem.

    For example, the Microsoft repository for Ubuntu 16.04 is missing Microsoft R Client MicrosoftML 3.5.2. Specifically, this does not exist:

    The pre-trained models for 3.5.2 are available but they require MicrosoftML so they cannot be used. This indicates that the missing MicrosoftML 3.5.2 package was likely a mistake rather than a purposeful exclusion.

    How can one install the full R Client 3.5.2 on Linux when the packages are simply not available.

    Friday, October 11, 2019 8:16 PM

All replies

  • Did you follow the Linux Microsoft R Client Instructions outlined here?

    This lists the correct steps for a complete online install of Microsoft R Client for Linux:

    Friday, October 11, 2019 8:41 PM
  • Yes, I tried to follow that page. The issue is that the MicrosoftML for R client 3.5.2 package is missing, so I cannot complete the instructions on that page (which is leading to this post).

    Tuesday, October 15, 2019 4:09 PM
  • I just tried an install of Microsoft R Client on Ubuntu 16.04 following the instructions on the above page and all worked fine - MicrosoftML got installed to this location:  


    Are you looking in a different location for the library(libraries)??

    Wednesday, October 16, 2019 5:12 PM