none
PS2007/SQL2008: Cube Creation fails (ActiveX component can't create object) - it was OK before ?! RRS feed

  • Question

  • Hi folks,

    about 1,5 months ago I have set up a - 1 server - development environment for PS2007. I had installed all components on one Windows 2008 box. Everything worked fine, now I receive an error.

    • MOSS 2007
    • SQL 2008 SP1
    • MOPS 2007 SP2

    I have done the additional installation for the cube building part according to this page
    http://technet.microsoft.com/en-us/library/dd285466(office.12).aspx

  • Microsoft SQL Server Native Client (sqlncli.msi)
  • Microsoft SQL Server 2005 Management Objects Collection (sqlserver2005_xmo.msi)
  • Microsoft SQL Server 2005 Backwards Compatibility Components (SQLServer2005_BC.msi)

    Everything worked fine. Cubes were able to be built.. everything was good. In order to have Reports built I added

    • SSRS 2008
    • Reporting Services Addin for MOSS (rsSharePoint_x64)
    • Business Intelligence Development Studio (=Visual Studio for MSSQL)

    No CUs have been added to this box.

    NOW, Cube creation fails with the error:

    ULS LOG:
    [CBS] ProjectServerOlapCubeGenerator status: Analysis Services session failed with the following error: Failed to connect to the Analysis Services server <IPADDRESS>. Error: ActiveX component can't create object 08efbc13-299a-4abe-9021-c46887ca6915

    Eventlog says:

    SSP Name: SharedServices1
    PSError: CBSASConnectionFailure (17003)
    Cube build failed to connect to the Analysis Services server. Verify the data source connection is valid. Error: Setting UID=00007829-4392-48b3-b533-5a5a4797e3c9 ASServerName=IPADDRESS ASDBName=ReportServer_Cubes ASExtraNetAddress=IPADDRESS RangeChoice=0 PastNum=1 PastUnit=0 NextNum=1 NextUnit=0 FromDate=09/03/2010 13:54:19 ToDate=09/03/2010 13:54:19 HighPriority=True

    Doing a little research give the hint that "Microsoft SQL Server 2005 Management Objects Collection (sqlserver2005_xmo.msi)" are not installed. But they are. I said OK... I will install it again, but it said "a newer version is already installed". I deinstalled the "Microsoft SQL Server 2005 Management Objects Collection (sqlserver2005_xmo.msi) " and tried to reinstall, but no success. It keeps saying a newer version is installed although it is definitely not installed.

    A similar blogentry can be found here:
    http://paulliebrand.com/2010/06/16/project-server-2007-error-activex-component-cant-create-object-when-building-cube/

    Can anyone help me to reinstall that "Microsoft SQL Server 2005 Management Objects Collection (sqlserver2005_xmo.msi)" ??

    thanks in advance!

    Sven

Friday, September 3, 2010 3:12 PM

Answers

  • I had the same issue. Try this update http://support.microsoft.com/kb/972511 click the "view and request hotfix downloads" at the top of the page. request the sql_server_2005_SP3_Cumulative_Update_5_XMO I installed this update and it solved my issue. Good luck!
    • Marked as answer by Sven W Friday, September 3, 2010 10:09 PM
    Friday, September 3, 2010 9:19 PM

All replies

  • I had the same issue. Try this update http://support.microsoft.com/kb/972511 click the "view and request hotfix downloads" at the top of the page. request the sql_server_2005_SP3_Cumulative_Update_5_XMO I installed this update and it solved my issue. Good luck!
    • Marked as answer by Sven W Friday, September 3, 2010 10:09 PM
    Friday, September 3, 2010 9:19 PM
  • Great! It works fine now.

    Thanks a lot!!

    Friday, September 3, 2010 10:09 PM