locked
Cannot find NT Service accounts RRS feed

  • Question

  • I am trying to go through the AdventureWorks tutorial.  When I try to add the login NT Service\MSSQLServerOLAPService to the database server logins, I get a message that the login cannot be found.  I have tried multiple variations of the login but none of them worked

    Sunday, June 19, 2016 1:50 PM

Answers

  • The service account might be different if you are using a named instance.

    Another way to grant access to the service account is to click the "Advanced..." button, change the Object Type setting to Groups and click Find. Then you should see a group with a name like SQLServerMSASUser$<machinename>$<instancename> - the service account is a member of that group, so if you can grant permissions to that. In fact granting permissions to this group is probably better than granting them directly to the account. If you ever change the service account SQL Configuration Manager will also put the new account in this group so the permissions would be retained. 


    http://darren.gosbell.com - please mark correct answers

    Sunday, June 19, 2016 8:39 PM