Conceptronic Wireless USB C54RU


  • Hi All,

     Just so you know that after installing SP3 my Conceptronic Wireless USB C54RU adaptor starting giving DLL errors on both startup services . I tried removing the Conceptronic device , reinstalling SP3 and reinstalling the USB adaptor but the errors reappear . I've now removed the Conceptronic adaptor and software until a fix is available .

    Wednesday, March 12, 2008 3:53 PM


  • Thanks for all your feedback. We've passed this on to the right teams and are looking into this.


    Thursday, March 13, 2008 10:28 PM

All replies

  • Hi,


    Can you please point us to a download location for the drivers if the adaptor?

    Can you also provide some details about the errors seen?





    Wednesday, March 12, 2008 6:45 PM
  • Hi ,

     I can't post the complete link to the drivers but if you go here :

     and search for C54RU you'll find them . After installation the program will install 2 new startup services . If I remember right they're called "APIO" and "WZ?????" . Anyway , both these services give an error during startup . Sorry , I didn't make a screenshot or write them down but it was something like input mapper library errors . Sorry to be so vague . Hopefully you can recreate the error .

    Wednesday, March 12, 2008 11:37 PM
  • Thanks for all your feedback. We've passed this on to the right teams and are looking into this.


    Thursday, March 13, 2008 10:28 PM

    I've got a Conceptronic c54Ri (one working with the same soft than yours) and also got the same DLL errors. I finaly fixed the problem replacing a pair of files in the Conceptronic folder (WlanMon.exe and WlanMon.dll) with the Vista version of them. These files are at .



    Thursday, May 15, 2008 9:38 PM
  • Thanks for the link but I can't seem to access the files.  Do you know if they are posted somewhere else?  Thanks again.

    Friday, June 27, 2008 4:59 PM
  • At the you can find a new driver. I tray it and it works like good.
    They have a same version of a driver for XP and Vista. (
    Here is a good XP driver which working in my thinkpad.
    Good luck!

    Saturday, August 02, 2008 8:29 PM
  • Hi all!

    I've downloaded that particular driver and I still get the same error initializing the conceptronic utility. Can you help?


    Saturday, August 23, 2008 2:31 PM

    According to Conceptronic support FAQ for C54RU, that driver is supposed to solve the issue with Service Pack 3 due to out-dated utility files  (WlanMon.exe and WlanMon.dll).


    Did you use the uninstaller feature through Add/Remove programs to remove the previous driver and utility before installing the newer version?  You should also unplug the USB adapter and restart at least once before attempting to install the new drivers.


    The C54RU adapter uses the Ralink USB R2500 WLAN chip.  You can try the latest drivers and utility available from Ralink:


    USB R25xx/26xx drivers and utility (34MB)


    Unplug the adapter, uninstall current drivers and utility, restart when prompted, plug the adapter again and cancel the new hardware wizard, then install the new driver package.

    Sunday, August 24, 2008 6:29 AM
  • Hi!!


    In fact the utility from conceptronic didn't work. I installed the ralink aplication and everything is working now.


    Thanks very much for your fast and fantastic help



    Sunday, August 24, 2008 12:02 PM

    Yeah, I learned a long time ago that drivers from the branding hardware vendor are usually out-dated or more problematic than the 'reference' drivers released by the device or chip manufacturer.  I've seen it two dozen times, and branding WLAN vendors seem to be among the worst.  Unfortunately, Broadcom, Atheros, and Texas Instruments don't release drivers to the public, only to their OEM customers, so obtaining the latest compatible drivers can be a challenge.

    Sunday, August 24, 2008 2:56 PM
  • Same problem here. I updated with SP3 and now i get the Wlanmon.exe message. Anyone has an idea to fix it? Thanks.
    Sunday, August 24, 2008 6:13 PM