locked
Notification Template with Hyperlink to Cireson support portal RRS feed

  • Question

  • Hello,

    Currently in the process of creating a notification template that will notify Reviewers that they have an approval/rejection waiting their acknowledgement. I am running into an issue where the hyperlink does not go anywhere(the Service Request ID is missing from the link) Below is an example with company specific information removed.

    From within template: 

    You can review the request: <a href="http://supportportal.com/ServiceRequest/Edit/$Context/Path[Relationship='WorkItem!System.WorkItemHasParentWorkItem' TypeConstraint='WorkItem!System.WorkItem']/Property[Type='WorkItem!System.WorkItem']/Id$">Click here</a>

    After receiving the email, the hyperlink goes to http://supportportal.com/ServiceRequest/Edit//.

    Any help would be appreciated.

    Thanks.

    Thursday, January 14, 2016 4:14 PM

Answers


  • The notification is triggered when the Review Activity status changed from Pending to In Progress?

    Than you could use http://<portalserver>/Activity/Edit/<ID>


    Andreas Baumgarten | H&D International Group

    Friday, January 15, 2016 10:09 PM

All replies


  • The notification is triggered when the Review Activity status changed from Pending to In Progress?

    Than you could use http://<portalserver>/Activity/Edit/<ID>


    Andreas Baumgarten | H&D International Group

    Friday, January 15, 2016 10:09 PM
  • Correct. The problem is that the ID is not being populated at the end of the hyperlink. It's only showing blank.
    Tuesday, January 19, 2016 6:01 PM
  • For Manual Activities it should be: $Context/Property[Type='CustomSystem_WorkItem_Library!System.WorkItem']/Id$

    For Review Activities ist should be: $Context/Property[Type='CustomSystem_WorkItem_Library!System.WorkItem']/Id$

    For both click on "Insert ..." button and select the "ID" in the "Work Item" section on the right list.


    Andreas Baumgarten | H&D International Group

    Wednesday, January 20, 2016 2:06 PM
  • I appreciate you taking the time to assist me with this. However, the bigger issue is that the Cireson portal uses the SR number in the hyperlink and not the MA or RA. So adding either MA, RA, or PA to the hyperlink will unfortunately go to a blank page.
    Wednesday, January 20, 2016 3:23 PM
  • In the knowledge base of the Cireson Support Portal (https://support.cireson.com) is an article named "How To Configure Email Notifications with URLs That Link to the Cireson Portal". Based on this article it's possible to use a hyperlink in the portal directly with Activities.

    http://myserver/Activity/Edit/<ID>

    Make sure you don't use this to address an Activity: http://myserve/ServiceRequest/Edit/<ID>

    Maybe you can check the article in the Support Portal of Cireson by yourself.


    Andreas Baumgarten | H&D International Group

    Wednesday, January 20, 2016 4:12 PM
  • Hi,

    If the issue has been resolved, please mark it as "Answered".By marking Answers you increase the chances that others searching this forum will find the answer directly rather than re-posting the question.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 25, 2016 3:27 AM