none
UEFI - No bootable device found

    Question

  • Hi,

    We just received some Latitude 7250 that are booting in UEFI. Our MDT deployment servers image just fine all our models but this one that is set in UEFI start deploying but after the first reboot we get "No bootable device found"

    What do we need to do to get UEFI deploy as old legacy BIOS?


    Friday, May 22, 2015 10:01 AM

All replies

  • To deploy UEFI you'll need to edit your task sequence that IfUEFI is true (which it is) your hard drive will be partitioned with Guided Partition Tables opposed to Master Boot Records which is currently the way to format drive's for legacy BIOS.

    This can be done easy, by opening the task sequence and copy your format & partition step, rename one to "Format & Partition MBR" and the other one to: "Format & Partition GPT", then modify that step to format the drive with GPT instead of MBR. After that go to the options/condition pane and add a task sequence variable for the MBR step: IsUEFI equals False and for the GPT step: IsUEFI equals True.

    That should do the trick. This way you can make use of the UEFI advantages your system has to offer. Otherwise you should consider putting all your new UEFI machines into legacy bios mode.


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Friday, May 22, 2015 2:16 PM
  • If you're running the latest MDT you don't need to modify your task sequence to get it to work with UEFI. Your MDT boot image must be 64bit and if you're using a flash drive it needs to be FAT32 formatted to be compatible with UEFI.

    If for some reason you don't want to use UEFI/Secure boot then you can go into the BIOS of your Dell machine and change it to Legacy boot mode.

    Go to Advanced Boot Options and check the box to enable legacy option. Go to Secure boot and disable it.

    Once you do that the option for Legacy boot will no longer be greyed out, you can then select it.

    Personally I prefer to use UEFI but I mostly deploy Windows 8.1


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, May 22, 2015 7:24 PM
  • Is it MDT 2013? If yes then you have to do nothing. 

    Can you share the BDD.log and ZTIDiskpart.log for one such deployment so that we can see what is going wrong here?

    regards,


    Mayank Sharma Support Engineer at Microsoft working in Enterprise Platform Support.

    Sunday, May 24, 2015 7:52 PM
  • Hello 

    I am having same issue on 7250 , 7280 

    have you been able to figure this out?

    thanks

    Tuesday, June 12, 2018 7:46 PM
  • legay Mode works fine

    the question is how to get UEFI work properly.

    mine does the same thing, it PEX boots ok while on UEFI Bios but it show " no boot device found" after first reboot.

    Tuesday, June 12, 2018 7:49 PM
  • Are you using latest MDT iteration for deployment? If you came from an older version of MDT, did you recreate your TS, which in turn adds necessary steps for UEFI deployments? If everything above is not applicable, could you share your BDD log?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Wednesday, June 13, 2018 7:23 AM
  • it doesn't even PXEBoot , TS comes after that.

    and yes I am using the latest version of MDT which againg does not have anything to do with PXEboot.

    I was able to fix it though.

    Since I am running  WDS and DHCP on same server and same network as clients are, my settings are a bit different.

    option 060 was causing the problem. UEFI PXEboot started to work once I removed the check box shown in the picture from WDS- DHCP tab, and form DHCP policy options.

    you can follow thes instructions on setting up the policy option , but do not setup  Option 060


    • Proposed as answer by Saeidans Thursday, June 21, 2018 8:14 PM
    • Edited by Saeidans Thursday, June 21, 2018 8:15 PM
    Thursday, June 21, 2018 8:14 PM