locked
Slow Windows Media Player startup when playing MP3 files RRS feed

  • Question

  • Hello there and apologies if it has been posted before (though I couldn't find it anywhere). I have two PCs running Windows Vista Business 32-bit since the RTM version. In other words they have survived long enough to download updates via Windows Updates, install both Service Packs etc.
    For some time now I experience the 10 - 25 second delay when playing a MP3 file in WMP. This delay appears to happen only once per Windows boot. Now, this does sound odd so I've tried to troubleshoot myself. When playing an MP3 file WMP launches mfpmp.exe file and this is how it's meant to be even though the files aren't DRM protected. Using Process Monitor I've found that before the process launches wmplayer.exe "pokes around" %systemroot%\system32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} folder. By "poking around" I mean querying file information (among other things) on most if not on every file. This introduces the delay during startup of playback as there are about 1400 *.cat files around. It can be clearly seen in Process Monitor summary that it takes even 25 seconds (depending on other hard disk activity) to "get through" the folder. It appears that the module responsible for file activity is CI.dll (code integrity). I would speculate that verifying the signatures (or whatever it's doing at this point) is a prerequisite to the launch of mfpmp.exe which plays the MP3 file. However WMP is checking the *.cat files that doesn't appear to be relevant to media playback (like the Remote Assistance update etc). The issue also happens if I launch WMP first and then select MP3 file from Media Library. The delay occurs as soon as I attempt to play the file. Afterwards it's all OK until the next reboot or (sometimes) until the next day.
    I took a look at a prefetch file for wmplayer.exe and I could see that over time the files from catroot folder are mentioned there as it just gets a little faster in the future. Nevertheless it's a little annoying. I've disabled the "Check for publisher's certificate revocation" setting via Internet Options. According to CAPI2 log it seemed that wmplayer.exe was trying to obtain those from the network. It didn't really help with the *.cat files scan. I've tried to disable WMP plugins, turn off visualization, disable all sound enhancements in the Windows Audio properties. Unfortunately if didn't help. I believe there is no other software running in the backgrund that could considerably slow things down (if anything there is an antivirus software on one PC and Windows Defender only on the other).
    Removing the oldest *.cat files as well as mfpmp.exe seems pretty dangerous.

    My questions are:
    1. Have anyone noticed the same issue or is it just me and those two PCs?
    2. Is there any way to disable code integrity checks or limit them (daily, monthly, per process)?
    3. Is there something else I should try?

    Thanks for any input you can give me.
    • Edited by Emkay1001 Wednesday, November 4, 2009 10:34 AM typo
    Wednesday, November 4, 2009 10:25 AM

All replies

  • Yes, I think I am having a very similar issue. Have you been able to figure out a fix for this?
    Saturday, February 6, 2010 8:57 PM
  • Not really. From what I read and understood, the "Code Integrity" check should be done before running mfpmp.exe. It's just the delay and scanning all the *.cat files that is weird. Even weirder is the fact that sometimes MP3 files play instantly. I've recently tried this (pretty much from despair).
    How long have it been since you had reinstalled Windows? Maybe the issue only happens when there is too many catalog files (note that removing them may lead to problems with playing DRM content or with Windows Update) that appear after downloading Windows updates and installing signed drivers. If you wish to find out when your Windows was installed, open Command Prompt and enter wmic os Get InstallDate and wait a while. The first eight numbers indicate a date.
    Sunday, February 7, 2010 2:22 PM
  • I found another thread with a similar question and the issue turned out to be the audio card drivers.

    See http://forums.techarena.in/media-player/1067879.htm

    I updated my Realtek HD drivers and all works fine now so it's worth a try...

     

    Thursday, October 14, 2010 10:19 PM
  • Updating drivers (which I do quite regularly) didn't seem to help in my case. The issue also occurs on a "clean install" of 32-bit Windows Vista Business RTM (and after installing all the updates from Windows Update) so it just may be intended.

    I'm just curious what triggers the "Code Integrity" check? Why doesn't it always happen? Why doesn't it happen after one reboot but happens after another? Oh well, yet another mystery of the universe...

    Wednesday, October 27, 2010 9:45 AM
  • Have you found a solution?

    I have a similar problem and tried a lot.

    I post a question here:

    http://superuser.com/questions/276178/delay-when-playing-soundfiles

    Wednesday, April 27, 2011 8:45 PM
  • Hello,

    The problem I'm experiencing only seems to affect Windows Vista and Windows Media Player 11. Before initiating MP3 playback the operating system verifies it's integrity (for example checks the file signatures). This causes the delay (you can notice an increase hard disk activity while files are check for valid signatures).

    In your case I would try to update your sound card drivers (or perhaps revert to the drivers that came with your Windows 7) and try to play the sound files in a "clean boot" environment (more can be found here: http://support.microsoft.com/kb/331796)

    Thursday, April 28, 2011 6:18 PM
  • Unfortunately I wasn't able to solve this problem (to get things to work with Windows 7). I tried a lot of different things:
    • Uninstall all 3:rd party software (clean Windows install)
    • Old and new sound card drivers
    • External USB sound card
    • Etc etc.

    I guess it is a combination of different things (hardware and software) that causes the problem, but I couldn't find it.

    So finally I gave up and installed Windows XP on that computer (and everything works nicely)!

    Monday, May 23, 2011 7:34 PM
  • I have the exact same behavior for years now with WMP. I just want to add that one thing that might help the diagnosis. It is not just the stand-alone WMP. This also happens with any MP3 playing using WMP resources. For example, after a fresh boot, pick your favourite station in www.radionomy.com. Press play and wait, wait alot for intense disk thrashing. Pressing F12 in the browser window, one discovers that it uses an <object classid="6BF52A52-394A-11d3-B153-00C04F79FAA6" /> to play. This class id corresponds to wmploc.dll, having description "Windows Media Player Resources".
    Saturday, March 24, 2012 7:06 PM
  • I had this same issue yesterday (Sept 1, 2020), and all I did was a cold reboot. I had timed an 8 second delay from the moment of clicking the MP3 and the actual start of play. After the reboot? NO delay. Sometimes, cold reboots can work wonders.
    • Edited by apiceno Wednesday, September 2, 2020 5:16 PM bad spelling
    Wednesday, September 2, 2020 5:15 PM