locked
SharPoint DLL version mismatch RRS feed

  • Question

  • Hi everyone,

    Wondering whether anyone can suggest how I can correct the DLL version mismatch between my SharePoint DLL and SharePoint Portal DLL.

    This is a SharePoint 2 servers farm (1 WFE and 1 Application Server running on Windows 2003 SP2) with SP2 applied. From CA 'servers in the farm' page it shows 12.0.0.6545 for both servers. But the actual DLL versions from the ISAPI folder are as follows:

    SharePoint.dll -> on App server 12.0.6545.5001 -> on WFE 12.0.6545.5002

    SharePoint.portal.dll -> on App server 12.0.6541.5000 -> on WFE 12.0.6541.5000

    As far as I know I installed the August 10 CU (WSS, MOSS) on both severs - ran PSCONFIG properly after with no luck. Should I even be bothered by this mismatch?

    Any suggestions would be greatly appreciated.

    Thank you!

     ========================

    Just to add some more information about this issue - when I checked the add/remove program on the WFE I noticed the KB2276472 (aug 10 cu) is not shown but it shows multiple times for each of my installed lanaguage packs on the App server. KB2276474 seems fine on both servers. So I tried to re-install the KB2276472 on the WFE but I get an error message "the expected version of the product was not found in this system". Any thoughts?


    BlueSky2010

    • Edited by BlueSky2010 Sunday, December 5, 2010 3:19 PM Adding more information
    Sunday, December 5, 2010 2:39 PM

All replies

  • Hi,

    After research, I found that you had installed Kb2276474(sharepoint.dll:12.0.6545.5001) in your Application server but you had not installed it in WFE, in WFE you have installed Kb2389628(Microsoft.sharepoint.dll:12.0.6545.5002).

     

    When deploy software update for moss 2007, you must install the update on every server that is running Office SharePoint Server 2007 in the server farm before you complete the installation on any one server that is running Office SharePoint Server 2007.  And you must ensure that the files for the Windows SharePoint Services 3.0 software update are installed on the servers before you install the Office SharePoint Server 2007 software update.

     

    For more information, please refer to: http://technet.microsoft.com/en-us/library/cc263467(office.12).aspx

     

    Hope it helps.


    Xue-Mei Chang
    Wednesday, December 8, 2010 6:52 AM
    Moderator
  • Thanks for looking into this Xue-Mei and sorry for this late response.

    Looks like I gave you wrong link with the WSS KB above - I actually installed August 2010 cumulative updates for both wss and moss.

    For Wss I tried installing from this link: http://support.microsoft.com/kb/2276474 (not Kb2389628)

    For MOSS I installed - http://support.microsoft.com/kb/2276472

    From the add remove programs - On my APP server I can see both KB2276474 and KB2276472 applied (though KB2276472 shows up multiple time as I mentioned in my earlier post) but on the WFE KB2276472 is not applied somehow (though I ran the installer and Config wizard after). To give you some background the Config Wizard  failed on one server (can't remember now on which one) and I had to run psconfig through command line (psconfig -cmd upgrade -inplace b2b -wait –force) to finish the Wizard.

    Looks to me something went very wrong somewhere - now neither I can install the missing KB2276472 on the WFE nor I can uninstall it from the APP server to fix the mismatch on the DLL files.

    I'm planning to apply the October Cumulative update - hoping that would fix this issue - what do you think?

    Any suggestions would be greatly appreciated.

    Thank you again!


    BlueSky2010
    Wednesday, December 15, 2010 5:20 PM