AppFabric Cumulative Update will not install


  • I have a server that was previously used for SharePoint 2010 Foundation (Server 2008 R2 SP1 Standard, SQL 2008 R2 SP1).  SP 2010 was removed, and all roles were removed from the server.   When the pre-req installer for 2013 Foundation runs, everything installs fine except for the AppFabric Cumulative update (note - AppFabric itself installed without issue and appears in the list of programs).   The pre-req installer states "installation failed" and if left alone, would repeatedly attempt install and reboot.   With an account that is set up as local administrator, domain user,  I have tried the following:

    1.  Download the cumulative update and run manually (An unexpected internal error has occurred). 

    2.  Download and attempt install of AppFabric CU 2 and 3 instead of 1 (same error)

    3.  Uninstall AppFabric, remove PSModulePath reg entry, reinstall AppFabric with pre-req installer, then apply CU (same error)

    4.  Confirmed PSModulePath does not have additional symbols like " at the beginning or end

    5.  Prereq install log shows install process returned (-1) but provides no additional information on why it failed, AppServerSetup log does not show any errors

    6.  Stopped and disabled Firewall, Defender, Antivirus

    7.  Extracted the files and tried to run the Setup.exe directly (unexpected internal error)

    8.  Disabled group policy, applied gpupdate, rebooted and confirm policy removed

    At this point, I'm at a loss for what to do. I cannot reformat the server because it runs ApplicationXtender which for now is still a critical app.  EMC says they don't support "integration" with SharePoint past 2010 SP1 and doesn't have any data on compatibility to run on the same server. 

    Do I just cut my losses at this point and wait until there are more resources available for a new VM (coming in a month or two) or does anyone have additional ideas for why this cumulative update won't install?  Everyone is excited about getting SharePoint and I hate to break momentum to wait for a new server.  I understand I could call MS support but I'm not sure that would be approved with the limited budget.


    Wednesday, January 30, 2013 3:15 PM

All replies

  • I have the same problem with the cumulative update. Did you find any solution?

    Thursday, September 26, 2013 10:06 PM
  • I was having that problem.  I would try to uninstall CU1 update from the "Installed Updates" but I would get "an unexpected internal error has occurred".  My solution was to *reinstall* appfabric (which was already uninstalled, but not this update) THEN uninstall this CU1 THEN uninstall appfabric again.

    Friday, November 22, 2013 6:59 PM