none
Access Denied on PWA 2010 for two of my resources RRS feed

  • Question

  • Hi,

    My Project Server 2010 was working fine for several months but suddently 2 of my resources cannot connect anymore to PWA : Access Denied.

    I didn't change any setting of my resources. What could happen?

    Thanks for any idea

    Sunday, February 27, 2011 10:54 PM

Answers

  • Hi,

    sorry that it takes that long this time .... There are many possible reasons for an access denied.

    Since you can act as delegate for them, you don't have any issue with permissions or account status within Project Web App. Please don't be angry, but are you sure that windows account is still active and you are using the correct password? I know by your answer to Ben, that AD account ist still active, can password be expired?

    Regards
    Barbara

    • Marked as answer by WLID1966 Monday, February 28, 2011 12:07 PM
    Monday, February 28, 2011 11:53 AM
    Moderator

All replies

  • Hi,

    you changed permissions two days ago. I have seen an issue regarding permissions, after changing categories, while users with these categories were logged in. Not sure if it was really the cause, but there was at least this time relationship.

    Have you tried to remove these resources from their groups, check when queue is finished and add them beack to their groups. Does that help?

    Regards
    Barbara

    Monday, February 28, 2011 6:22 AM
    Moderator
  • I tried to remove these resources from their groups, and then add them back, but to no avail ;-(

    Thanks for trying.

    Monday, February 28, 2011 9:01 AM
  • Sorry, I can't follow? AReen't you able to remove them or to add them back or doesn't resolve this your issue. Have you checked the status of these resources? Are they still active?

    Please let me know!
    Barbara

    Monday, February 28, 2011 9:28 AM
    Moderator
  • And in addition to Barbara's excellent answer, have they been disabled in Active Directory?
    Ben Howard [MVP] blog | web
    Monday, February 28, 2011 9:36 AM
    Moderator
  • Sorry,

    I was able to remove them and to add them back in their groups, but that didn't solve the issue.

    Monday, February 28, 2011 9:46 AM
  • Hi Ben,

    They are still active in AD

     

    Monday, February 28, 2011 9:47 AM
  • The 2 ressources  were still active.

    I deactivated these 2 ressources and a few minutes after I reactivated them. But that didn't solve the issue.

    Monday, February 28, 2011 9:50 AM
  • Hi,

    do you see "Access denied" immediately when starting Project Web Access or on a particular page (should have been my first question)?

    Barbara

    Monday, February 28, 2011 9:55 AM
    Moderator
  • I synched all the resources with their AD group : the synch succeeded (nothing in the queue) but that didn't solve the issue for these 2 resources.  they sitll cannot connect to PWA
    Monday, February 28, 2011 9:58 AM
  • OK, seems this is answers my last question, they can't access Project Web Access at all. Could you please try to remove one of them from all groups, check that no category is selected and no Global permissions is defined for this resource (Server Settings - Manage Resources). Add group Administrators for this resource. I would like to narrow done, if there is any permisson issue for this resource or anything related to AD account, password, IE settings, ....

    Regards
    Barbara

    Monday, February 28, 2011 10:04 AM
    Moderator
  • Yes, the get Access Denied immediately when starting Project Web Access, when they enter their user name end password.
    Monday, February 28, 2011 10:28 AM
  • I did that for one of the 2 resources:

    • Removed every groups
    • Removed every categories
    • saved
    • Get back and added Administrators group
    • Saved

    Disappointement : while Administrator, this user cannot connect to PWA

    Monday, February 28, 2011 10:43 AM
  • Grrrrr .... There was no "Deny" in Global Permissions on Resource level?

    What happens if you act as delegate for one of them? As far as I remember, you have already used this feature.

    Sorry for asking that many questions!
    Regards
    Barbara

    Monday, February 28, 2011 10:56 AM
    Moderator
  • Barbara,

    Thanks for trying so hard!

    I was able to work as a delegate for these 2 resources. I filled one timesheet for each of them and when I came back as myself I found their timesheets in my Approval Center ! 

     

     

    Monday, February 28, 2011 11:38 AM
  • Hi,

    sorry that it takes that long this time .... There are many possible reasons for an access denied.

    Since you can act as delegate for them, you don't have any issue with permissions or account status within Project Web App. Please don't be angry, but are you sure that windows account is still active and you are using the correct password? I know by your answer to Ben, that AD account ist still active, can password be expired?

    Regards
    Barbara

    • Marked as answer by WLID1966 Monday, February 28, 2011 12:07 PM
    Monday, February 28, 2011 11:53 AM
    Moderator
  • Barbara, You found it!

    In AD, for these two resources, the box "Password never expire" was not checked!!!

    I just clicked on it and now the two resources can log on PWA!!!

    1000 thanks!

    Monday, February 28, 2011 12:12 PM
  • LOL
    Sorry, that it took so long for such a trivial one ;-)!

    Regards
    Barbara

    Monday, February 28, 2011 12:13 PM
    Moderator
  • Barbara --

    You are truly a computer genius...and a very patient one as well!  :)


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Monday, February 28, 2011 10:37 PM
    Moderator