locked
remote management fails to connect RRS feed

  • Question

  • 2 newly built W2k8 R2 servers, same domain. Windows Firewall is disabled on both.
    Via Server Manager, I cannot connect from one server to the other. 
    I enabled 'Allow automatic configuration of listeners' on both servers
    I also ran 'winrm quickconfig' on both
    Windows remote mgmt service is started and set to Automatic on both
    I still get the error "the client cannot connect to the destination specified in the request"
    I am logged into the originating server as the domain admin, so it is not a permissions issue.
    What am I missing?
    Thanks!

    Tuesday, December 1, 2009 1:22 PM

Answers

  • Had a similar problem and tried similar steps.  The following worked for me:

    On the destination server,

    In Group Policy,  computer configuration, administrative templates, Windows components, Windows remote management, winrm service, enable automatic configuration of listeners and key an * in ipv4 filter – or key a   specific address.   In windows remote shell, enable remote shell access.

    Sorry for the inadvertent mouse click on propose as answer from Marco. 


    rd
    • Marked as answer by Tim Quan Thursday, January 7, 2010 8:33 AM
    Wednesday, December 2, 2009 4:59 PM

All replies

  • I'm going to try to help you out.  My virtual machines aren't agreeing with me right now, so it could be a few days...

    You also mention they are on the same domain.  I'm assuming neither of them is a DC themselves?
    Tuesday, December 1, 2009 5:31 PM
    Moderator
  • Can you go on both of the computers and try to connect to the other?  From DOS or PowerShell, try:
    DOS>winrm id -r:http://remote_server:5985

    remote_server needs to be the true hostname of the remote server.  Since you are joined to a domain, that should be what is in the DNS also (if you try to do a nslookup, for example).
    • Proposed as answer by rjdjr Wednesday, December 2, 2009 4:35 PM
    • Unproposed as answer by Marco ShawModerator Wednesday, December 2, 2009 7:25 PM
    Wednesday, December 2, 2009 2:25 AM
    Moderator
  • Had a similar problem and tried similar steps.  The following worked for me:

    On the destination server,

    In Group Policy,  computer configuration, administrative templates, Windows components, Windows remote management, winrm service, enable automatic configuration of listeners and key an * in ipv4 filter – or key a   specific address.   In windows remote shell, enable remote shell access.

    Sorry for the inadvertent mouse click on propose as answer from Marco. 


    rd
    • Marked as answer by Tim Quan Thursday, January 7, 2010 8:33 AM
    Wednesday, December 2, 2009 4:59 PM
  • hi metoo2,

    did rjdjr's solution fix your problem here?
    Wednesday, December 23, 2009 7:34 AM
  • 2 newly built W2k8 R2 servers, same domain. Windows Firewall is disabled on both.
    Via Server Manager, I cannot connect from one server to the other. 
    I enabled 'Allow automatic configuration of listeners' on both servers
    I also ran 'winrm quickconfig' on both
    Windows remote mgmt service is started and set to Automatic on both
    I still get the error "the client cannot connect to the destination specified in the request"
    I am logged into the originating server as the domain admin, so it is not a permissions issue.
    What am I missing?
    Thanks!

    Make sure to check this out: http://support.microsoft.com/kb/976839/
    Wednesday, December 23, 2009 5:37 PM
    Moderator
  • You have to run specific command in administrative mode (Run as Administrator on CMD) on machine which you want to manage remotly:

    winrm quickconfig

    It will tell you what is enabled and what is not.

    I had the same issue and just ran this command, followed up instruction, chosed 'Y' when I was asked if command should update my server's config and that's all!

    Tuesday, June 1, 2010 11:09 AM